summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-cpp/gtest/Manifest1
-rw-r--r--dev-cpp/gtest/files/configure-fix-pthread-linking.patch93
-rw-r--r--dev-cpp/gtest/gtest-1.7.0-r1.ebuild50
3 files changed, 0 insertions, 144 deletions
diff --git a/dev-cpp/gtest/Manifest b/dev-cpp/gtest/Manifest
index 263c2954cefa..63ceaa70e4ab 100644
--- a/dev-cpp/gtest/Manifest
+++ b/dev-cpp/gtest/Manifest
@@ -1,4 +1,3 @@
-DIST gtest-1.7.0.tar.gz 1001582 BLAKE2B 3d10c1e502c2fac1500d07301031a9328b29027a3f9719137e09d2c47556cf52bbc978a8fb7b37330a94beafa27d24c3bfc247b2f0d51306b53f43e7ae2373b4 SHA512 a9f5c047b39efb2d11b55ee9913662ca402ac6837b3ad2d278ecfbd1caf32ed4546f169e3e92503d57bf3b62ccf89cd062da1c7ea3638aae98e868d2766363c3
DIST gtest-1.8.0.tar.gz 1281617 BLAKE2B ac052b4d0eb0d8ded03a8c7dff05177818627b8a51f2dbc2c162b2ee2a5d1323539e7d0d02236d9ebb799995e018f0171c2fdaeb4de3bb339548265e50de79e6 SHA512 1dbece324473e53a83a60601b02c92c089f5d314761351974e097b2cf4d24af4296f9eb8653b6b03b1e363d9c5f793897acae1f0c7ac40149216035c4d395d9d
DIST gtest-1.8.1.tar.gz 992298 BLAKE2B 40ef3417fe424205c0617f07207347ce671ac87605f8ac9b8a333b0b06e3fbef9f556041ee324c18f957f3258ab9fe06704f31cdd038355fb7890180eb77ced1 SHA512 e6283c667558e1fd6e49fa96e52af0e415a3c8037afe1d28b7ff1ec4c2ef8f49beb70a9327b7fc77eb4052a58c4ccad8b5260ec90e4bceeac7a46ff59c4369d7
DIST gtest-1.9.0_pre20190607.tar.gz 958396 BLAKE2B 64ae2c86a320a6ed56d6f99383591f7a0176e3f1291144bddf6dc82733c78177963f95516bbaed494318d3d7451d164aeb0d4a192b415414bcc25b9875cf6e82 SHA512 6c17ba303ec1dc8a989075a6dc0eda9b023345d00f6b43e588676cc2cd291f8c508744e4aba86a6c6b651329ce47419ad04d5765ca5978eda507a1643e8a92c3
diff --git a/dev-cpp/gtest/files/configure-fix-pthread-linking.patch b/dev-cpp/gtest/files/configure-fix-pthread-linking.patch
deleted file mode 100644
index 75e5219b7a7c..000000000000
--- a/dev-cpp/gtest/files/configure-fix-pthread-linking.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-From fb71154012e634a5e780e93af5434bcdafaf2b24 Mon Sep 17 00:00:00 2001
-From: Justin Bronder <jsbronder@gmail.com>
-Date: Mon, 15 Oct 2012 17:25:07 -0400
-Subject: [PATCH] configure: fix pthread linking
-
-- Update the pthread check to make sure that we don't need -lpthread when
-compiling with -nostdlib.
-
-- Make sure that the necessary pthread library is passed to libtool.
-
-Fixes:
-
-$ ldd -r /usr/lib/libgtest.so
- linux-vdso.so.1 (0x00007fffe7dff000)
- libstdc++.so.6 => /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so.6 (0x00007fbe09a9f000)
- libc.so.6 => /lib64/libc.so.6 (0x00007fbe096f7000)
- libgcc_s.so.1 => /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libgcc_s.so.1 (0x00007fbe094e1000)
- libm.so.6 => /lib64/libm.so.6 (0x00007fbe091ee000)
- /lib64/ld-linux-x86-64.so.2 (0x00007fbe0a005000)
-undefined symbol: pthread_key_create (/usr/lib/libgtest.so)
-undefined symbol: pthread_getspecific (/usr/lib/libgtest.so)
-undefined symbol: pthread_key_delete (/usr/lib/libgtest.so)
-undefined symbol: pthread_setspecific (/usr/lib/libgtest.so)
----
- Makefile.am | 1 +
- m4/acx_pthread.m4 | 39 ++++++++++++++++++++++++++++++++++++++-
- 2 files changed, 39 insertions(+), 1 deletions(-)
-
-diff --git a/Makefile.am b/Makefile.am
-index cb350b7..db2606e 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -181,6 +181,7 @@ endif
- lib_LTLIBRARIES = lib/libgtest.la lib/libgtest_main.la
-
- lib_libgtest_la_SOURCES = src/gtest-all.cc
-+lib_libgtest_la_LIBADD = $(AM_LIBS)
-
- pkginclude_HEADERS = \
- include/gtest/gtest-death-test.h \
-diff --git a/m4/acx_pthread.m4 b/m4/acx_pthread.m4
-index 2cf20de..7fba4d9 100644
---- a/m4/acx_pthread.m4
-+++ b/m4/acx_pthread.m4
-@@ -339,7 +339,44 @@ if test "x$acx_pthread_ok" = xyes; then
- # so it's not safe to assume that we may use pthreads
- acx_pthread_ok=no
- fi
--
-+
-+ AC_MSG_CHECKING([whether what we have so far is sufficient with -nostdlib])
-+ CFLAGS="-nostdlib $CFLAGS"
-+ # we need c with nostdlib
-+ LIBS="$LIBS -lc"
-+ AC_TRY_LINK([#include <pthread.h>],
-+ [pthread_t th; pthread_join(th, 0);
-+ pthread_attr_init(0); pthread_cleanup_push(0, 0);
-+ pthread_create(0,0,0,0); pthread_cleanup_pop(0); ],
-+ [done=yes],[done=no])
-+
-+ if test "x$done" = xyes; then
-+ AC_MSG_RESULT([yes])
-+ else
-+ AC_MSG_RESULT([no])
-+ fi
-+
-+ if test x"$done" = xno; then
-+ AC_MSG_CHECKING([whether -lpthread saves the day])
-+ LIBS="-lpthread $LIBS"
-+ AC_TRY_LINK([#include <pthread.h>],
-+ [pthread_t th; pthread_join(th, 0);
-+ pthread_attr_init(0); pthread_cleanup_push(0, 0);
-+ pthread_create(0,0,0,0); pthread_cleanup_pop(0); ],
-+ [done=yes],[done=no])
-+
-+ if test "x$done" = xyes; then
-+ AC_MSG_RESULT([yes])
-+ PTHREAD_LIBS="$PTHREAD_LIBS -lpthread"
-+ else
-+ AC_MSG_RESULT([no])
-+ AC_MSG_WARN([Impossible to determine how to use pthreads with shared libraries and -nostdlib])
-+ fi
-+ fi
-+
-+ CFLAGS="$save_CFLAGS"
-+ LIBS="$save_LIBS"
-+ CC="$save_CC"
- CFLAGS="$save_CFLAGS"
- LIBS="$save_LIBS"
- CC="$save_CC"
---
-1.7.8.6
-
diff --git a/dev-cpp/gtest/gtest-1.7.0-r1.ebuild b/dev-cpp/gtest/gtest-1.7.0-r1.ebuild
deleted file mode 100644
index 360809f62e74..000000000000
--- a/dev-cpp/gtest/gtest-1.7.0-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_IN_SOURCE_BUILD=1
-# Python is required for tests and some build tasks.
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils python-any-r1 autotools-multilib
-
-DESCRIPTION="Google C++ Testing Framework"
-HOMEPAGE="https://github.com/google/googletest"
-SRC_URI="https://github.com/google/googletest/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="examples static-libs"
-
-DEPEND="${PYTHON_DEPS}"
-RDEPEND=""
-
-PATCHES=(
- "${FILESDIR}/configure-fix-pthread-linking.patch" #371647
-)
-
-src_prepare() {
- sed -i -e "s|/tmp|${T}|g" test/gtest-filepath_test.cc || die
- sed -i -r \
- -e '/^install-(data|exec)-local:/s|^.*$|&\ndisabled-&|' \
- Makefile.am || die
- autotools-multilib_src_prepare
-}
-
-multilib_src_install() {
- default
- multilib_is_native_abi && dobin scripts/gtest-config
-}
-
-multilib_src_install_all() {
- prune_libtool_files --all
- einstalldocs
-
- if use examples ; then
- insinto /usr/share/doc/${PF}/examples
- doins samples/*.{cc,h}
- fi
-}