summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-benchmarks/httperf/Manifest1
-rw-r--r--app-benchmarks/httperf/httperf-0.9.1_p20161228.ebuild38
-rw-r--r--app-benchmarks/httperf/metadata.xml3
3 files changed, 42 insertions, 0 deletions
diff --git a/app-benchmarks/httperf/Manifest b/app-benchmarks/httperf/Manifest
index 6d19b0abf959..25d1636037e5 100644
--- a/app-benchmarks/httperf/Manifest
+++ b/app-benchmarks/httperf/Manifest
@@ -1 +1,2 @@
DIST httperf-0.9.0.tar.gz 425297 SHA256 e1a0bf56bcb746c04674c47b6cfa531fad24e45e9c6de02aea0d1c5f85a2bf1c SHA512 58ea6a3b8a82181a89e5df22fdf18d5be8c7b533c404108702cc03fc727fb1599a43e620d83d41630f8a951d80e48ed99d0c3dd8469ee1fc7626449b777971e1 WHIRLPOOL 7b36e636a063c9af7ff142f7a81947f5b693bb1a3bdbe98c5dfd1f5ac11edb380e97f19c3ad2a0a8d8505c0d63d8d714fe935a6e326f2373cbbb11a940431a7e
+DIST httperf-0.9.1_p20161228.tar.gz 106357 SHA256 45cf5e92d30cd4191015fff2d0d066b780b54c45e614690bf0e70926633715ed SHA512 e5dbb400e4ab0db3cc1621731d99af9261574a8a1da4279c722ebbd80537d0aae2a3d662f4d51eb9130bc98823c2786710c7819a0144f4ae3f8cf153e28d7dfa WHIRLPOOL 2d0e5ee38b965f8d378cf45038c03782bb64d73981432a24968d6e0b870bacd64e947ee6c0120b2d7927780c4096cf3725ff1866f5f77042498f278cc84683d6
diff --git a/app-benchmarks/httperf/httperf-0.9.1_p20161228.ebuild b/app-benchmarks/httperf/httperf-0.9.1_p20161228.ebuild
new file mode 100644
index 000000000000..55a180082410
--- /dev/null
+++ b/app-benchmarks/httperf/httperf-0.9.1_p20161228.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools vcs-snapshot
+
+MY_COMMIT_HASH="cc888437e4572ec29a4a7209f34fbd39c31600f5"
+
+DESCRIPTION="A tool from HP for measuring web server performance"
+HOMEPAGE="https://github.com/httperf/httperf"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+-with-openssl-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86 ~amd64-linux ~x64-macos"
+IUSE="debug libressl idleconn"
+
+RDEPEND="!libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ idleconn? ( dev-libs/libevent:0= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --bindir="${EPREFIX}"/usr/bin
+ $(use_enable debug)
+ $(use_enable idleconn)
+ )
+
+ econf "${myeconfargs[@]}"
+}
diff --git a/app-benchmarks/httperf/metadata.xml b/app-benchmarks/httperf/metadata.xml
index eb752516f0b8..63bcf7913a59 100644
--- a/app-benchmarks/httperf/metadata.xml
+++ b/app-benchmarks/httperf/metadata.xml
@@ -12,6 +12,9 @@
sustain server overload, support for the HTTP/1.1 and SSL protocols, and
its extensibility to new workload generators and performance
measurements.</longdescription>
+ <use>
+ <flag name="idleconn">Build with the idleconn program</flag>
+ </use>
<upstream>
<remote-id type="google-code">httperf</remote-id>
<remote-id type="github">httperf/httperf</remote-id>