summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/graphene/Manifest1
-rw-r--r--media-libs/graphene/graphene-1.8.2.ebuild60
2 files changed, 0 insertions, 61 deletions
diff --git a/media-libs/graphene/Manifest b/media-libs/graphene/Manifest
index 73776228315f..8b720d563f02 100644
--- a/media-libs/graphene/Manifest
+++ b/media-libs/graphene/Manifest
@@ -1,2 +1 @@
-DIST graphene-1.8.2.tar.xz 127436 BLAKE2B a22251db7cf4719c8a6cde49e6feb0a998d1ec7296fee549a4797d72fa575d4266e48fb5a6d9ebd204b93954a6278b4fa88dc56e5f86d7cf8625a5edc685a09b SHA512 8d250dccac345251081419f4ad7079c8035cb6225e10b23d25799386b067288831c23be667d608228ef44a2f6107ac47fc86bb495eda7881b1336598d6c43234
DIST graphene-1.8.6.tar.xz 127984 BLAKE2B 7f67b99796cca1a47324674b1871ddfbcce1193ded5f0a37c8c2894d52b6b5823b0fb1909018ea6adb90f7ed53ad6b09eeda9b1606a22a8b85cd0d661d500195 SHA512 ef6e9b5587bd540099216a7e3f7c86eb62368d49876dcd380c9767c6740c8267c9d510c5025dbe56402f3cd15084ef8fc634d3abe486b516f4f5328b87df277c
diff --git a/media-libs/graphene/graphene-1.8.2.ebuild b/media-libs/graphene/graphene-1.8.2.ebuild
deleted file mode 100644
index 9e2e37488754..000000000000
--- a/media-libs/graphene/graphene-1.8.2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{5,6,7} )
-inherit xdg-utils meson multilib-minimal python-any-r1
-
-DESCRIPTION="A thin layer of types for graphic libraries"
-HOMEPAGE="https://ebassi.github.io/graphene/"
-SRC_URI="https://github.com/ebassi/graphene/releases/download/${PV}/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm ~hppa ppc ppc64 ~sparc x86 ~amd64-fbsd"
-IUSE="cpu_flags_arm_neon cpu_flags_x86_sse2 doc +introspection test"
-
-RDEPEND="
- >=dev-libs/glib-2.30.0:2[${MULTILIB_USEDEP}]
- introspection? ( dev-libs/gobject-introspection:= )
-"
-# Python is only needed with USE=introspection or FEATURES=test, but not bothering with conditional python_setup
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- doc? ( dev-util/gtk-doc )
- virtual/pkgconfig
-"
-
-src_prepare() {
- xdg_environment_reset
- default
- # Disable installed-tests
- sed -e 's/install: true/install: false/g' -i src/tests/meson.build || die
-}
-
-multilib_src_configure() {
- # TODO: Do we want G_DISABLE_ASSERT as buildtype=release would do upstream?
- local emesonargs=(
- -Dgtk_doc=$(multilib_native_usex doc true false)
- -Dgobject_types=true
- -Dintrospection=$(multilib_native_usex introspection true false)
- -Dgcc_vector=true # if built-in support tests fail, it'll just not enable vector intrinsics; unfortunately this probably means disabled on clang too, due to it claiming to be <gcc-4.9
- $(meson_use cpu_flags_x86_sse2 sse2)
- $(meson_use cpu_flags_arm_neon arm_neon)
- $(meson_use test tests)
- -Dbenchmarks=false
- )
- meson_src_configure
-}
-
-multilib_src_compile() {
- meson_src_compile
-}
-
-multilib_src_test() {
- meson_src_test
-}
-
-multilib_src_install() {
- meson_src_install
-}