summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/lksctp-tools/lksctp-tools-1.0.13.ebuild5
-rw-r--r--net-misc/lksctp-tools/lksctp-tools-1.0.16.ebuild5
-rw-r--r--net-misc/lksctp-tools/lksctp-tools-1.0.17.ebuild5
3 files changed, 12 insertions, 3 deletions
diff --git a/net-misc/lksctp-tools/lksctp-tools-1.0.13.ebuild b/net-misc/lksctp-tools/lksctp-tools-1.0.13.ebuild
index 1b0f576b62ef..6d1e24c56655 100644
--- a/net-misc/lksctp-tools/lksctp-tools-1.0.13.ebuild
+++ b/net-misc/lksctp-tools/lksctp-tools-1.0.13.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit eutils multilib flag-o-matic autotools autotools-utils
+inherit eutils multilib flag-o-matic autotools autotools-utils linux-info
DESCRIPTION="Tools for Linux Kernel Stream Control Transmission Protocol implementation"
HOMEPAGE="http://lksctp.sourceforge.net/"
@@ -21,6 +21,9 @@ RDEPEND=""
REQUIRED_USE="kernel_linux"
+CONFIG_CHECK="~IP_SCTP"
+WARNING_IP_SCTP="CONFIG_IP_SCTP:\tis not set when it should be."
+
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.0.8-prefix.patch #181602
epatch "${FILESDIR}"/${P}-build.patch
diff --git a/net-misc/lksctp-tools/lksctp-tools-1.0.16.ebuild b/net-misc/lksctp-tools/lksctp-tools-1.0.16.ebuild
index 1ccb9b7dce92..8e916c902b71 100644
--- a/net-misc/lksctp-tools/lksctp-tools-1.0.16.ebuild
+++ b/net-misc/lksctp-tools/lksctp-tools-1.0.16.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit eutils multilib flag-o-matic autotools autotools-utils
+inherit eutils multilib flag-o-matic autotools autotools-utils linux-info
DESCRIPTION="Tools for Linux Kernel Stream Control Transmission Protocol implementation"
HOMEPAGE="http://lksctp.sourceforge.net/"
@@ -21,6 +21,9 @@ RDEPEND=""
REQUIRED_USE="kernel_linux"
+CONFIG_CHECK="~IP_SCTP"
+WARNING_IP_SCTP="CONFIG_IP_SCTP:\tis not set when it should be."
+
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.0.8-prefix.patch #181602
eautoreconf
diff --git a/net-misc/lksctp-tools/lksctp-tools-1.0.17.ebuild b/net-misc/lksctp-tools/lksctp-tools-1.0.17.ebuild
index 2d6ad050d3c0..fedd06cc6c17 100644
--- a/net-misc/lksctp-tools/lksctp-tools-1.0.17.ebuild
+++ b/net-misc/lksctp-tools/lksctp-tools-1.0.17.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit eutils multilib flag-o-matic autotools autotools-utils
+inherit eutils multilib flag-o-matic autotools autotools-utils linux-info
DESCRIPTION="Tools for Linux Kernel Stream Control Transmission Protocol implementation"
HOMEPAGE="http://lksctp.sourceforge.net/"
@@ -21,6 +21,9 @@ RDEPEND=""
REQUIRED_USE="kernel_linux"
+CONFIG_CHECK="~IP_SCTP"
+WARNING_IP_SCTP="CONFIG_IP_SCTP:\tis not set when it should be."
+
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.0.8-prefix.patch #181602
eautoreconf