summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/seetxt/files/seetxt-0.72-fno-common.patch24
-rw-r--r--x11-misc/seetxt/seetxt-0.72-r1.ebuild21
2 files changed, 36 insertions, 9 deletions
diff --git a/x11-misc/seetxt/files/seetxt-0.72-fno-common.patch b/x11-misc/seetxt/files/seetxt-0.72-fno-common.patch
new file mode 100644
index 000000000000..f1d69b20d42c
--- /dev/null
+++ b/x11-misc/seetxt/files/seetxt-0.72-fno-common.patch
@@ -0,0 +1,24 @@
+https://sources.debian.org/patches/see/0.72-7/40-fix_ftbfs.patch/
+https://bugs.gentoo.org/707402
+--- a/src/main.h
++++ b/src/main.h
+@@ -92,7 +92,8 @@ typedef struct {
+ struct matchspec {
+ int bgn;
+ int end;
+-} rgxp;
++};
++extern struct matchspec rgxp;
+
+ /* see.c */
+ void addtohistory (char *line);
+--- a/src/util.c
++++ b/src/util.c
+@@ -11,6 +11,7 @@ Public License along with this program.
+ #include "main.h"
+
+ char *EXDline, Me[64];
++struct matchspec rgxp;
+
+ int buflen (char *buffer) {
+ int blen = strlen(buffer), NofL=0, i;
diff --git a/x11-misc/seetxt/seetxt-0.72-r1.ebuild b/x11-misc/seetxt/seetxt-0.72-r1.ebuild
index a61c7e234474..db7394530239 100644
--- a/x11-misc/seetxt/seetxt-0.72-r1.ebuild
+++ b/x11-misc/seetxt/seetxt-0.72-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit autotools eutils
+inherit autotools
DESCRIPTION="Clever, lightweight GUI text file and manual page viewer for X windows"
HOMEPAGE="https://code.google.com/p/seetxt/ http://seetxt.sourceforge.net/"
@@ -12,16 +12,19 @@ SRC_URI="https://seetxt.googlecode.com/files/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
+BDEPEND="virtual/pkgconfig"
RDEPEND="x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-0001-fix-linking.patch"
+ "${FILESDIR}/${PV}-0002-fix-shared-files-install.patch"
+ "${FILESDIR}/${PN}-0.72-fno-common.patch"
+)
src_prepare() {
- epatch \
- "${FILESDIR}/${PV}-0001-fix-linking.patch" \
- "${FILESDIR}/${PV}-0002-fix-shared-files-install.patch"
+ default
eautoreconf
}