summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-block/mtx/files/mtx-1.3.12-fix-buildsystem.patch20
-rw-r--r--sys-block/mtx/mtx-1.3.12.ebuild14
2 files changed, 26 insertions, 8 deletions
diff --git a/sys-block/mtx/files/mtx-1.3.12-fix-buildsystem.patch b/sys-block/mtx/files/mtx-1.3.12-fix-buildsystem.patch
new file mode 100644
index 000000000000..6627bfac0504
--- /dev/null
+++ b/sys-block/mtx/files/mtx-1.3.12-fix-buildsystem.patch
@@ -0,0 +1,20 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -109,13 +109,13 @@
+ dbgs: $(DBGS)
+
+ install: $(BINS)
+- $(INSTALL_DIR) $(sbindir)
++ $(INSTALL_DIR) $(DESTDIR)$(sbindir)
+ for file in $(BINS); do \
+- $(INSTALL_BIN) "$$file" $(sbindir) ; \
++ $(INSTALL_BIN) "$$file" $(DESTDIR)$(sbindir) ; \
+ done
+- $(INSTALL_DIR) $(mandir) $(mandir)/man1
++ $(INSTALL_DIR) $(mandir) $(DESTDIR)$(mandir)/man1
+ for file in mtx.1 tapeinfo.1 scsitape.1 scsieject.1 loaderinfo.1 ; do \
+- $(INSTALL_DOC) "$$file" $(mandir)/man1 ; \
++ $(INSTALL_DOC) "$$file" $(DESTDIR)$(mandir)/man1 ; \
+ done
+
+ clean:
diff --git a/sys-block/mtx/mtx-1.3.12.ebuild b/sys-block/mtx/mtx-1.3.12.ebuild
index 0053c550bc54..593c08791e97 100644
--- a/sys-block/mtx/mtx-1.3.12.ebuild
+++ b/sys-block/mtx/mtx-1.3.12.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
DESCRIPTION="Utilities for controlling SCSI media changers and tape drives"
HOMEPAGE="https://sourceforge.net/projects/mtx/"
@@ -10,10 +10,8 @@ SRC_URI="mirror://sourceforge/mtx/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86"
-IUSE=""
-src_install () {
- einstall || die
- dodoc CHANGES COMPATABILITY FAQ README TODO
- dohtml mtxl.README.html
-}
+PATCHES=( "${FILESDIR}"/${P}-fix-buildsystem.patch )
+
+DOCS=( CHANGES COMPATABILITY FAQ README TODO )
+HTML_DOCS=( mtxl.README.html )