summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-arcade/xbubble/files/xbubble-0.5.8-libpng14.patch4
-rw-r--r--games-arcade/xbubble/files/xbubble-0.5.8-locale.patch4
-rw-r--r--games-arcade/xbubble/files/xbubble-0.5.8-png15.patch4
-rw-r--r--games-arcade/xbubble/files/xbubble-0.5.8-xpaths.patch4
-rw-r--r--games-arcade/xbubble/xbubble-0.5.8-r1.ebuild51
5 files changed, 59 insertions, 8 deletions
diff --git a/games-arcade/xbubble/files/xbubble-0.5.8-libpng14.patch b/games-arcade/xbubble/files/xbubble-0.5.8-libpng14.patch
index ad689e29d739..4fe12672db65 100644
--- a/games-arcade/xbubble/files/xbubble-0.5.8-libpng14.patch
+++ b/games-arcade/xbubble/files/xbubble-0.5.8-libpng14.patch
@@ -1,7 +1,7 @@
http://bugs.gentoo.org/show_bug.cgi?id=308731
---- src/loadpng.c
-+++ src/loadpng.c
+--- a/src/loadpng.c
++++ b/src/loadpng.c
@@ -55,7 +55,7 @@ unsigned char * load_png_file( const cha
}
/* ensure that we opened a PNG file */
diff --git a/games-arcade/xbubble/files/xbubble-0.5.8-locale.patch b/games-arcade/xbubble/files/xbubble-0.5.8-locale.patch
index a83d36fbd911..99c03b0c82af 100644
--- a/games-arcade/xbubble/files/xbubble-0.5.8-locale.patch
+++ b/games-arcade/xbubble/files/xbubble-0.5.8-locale.patch
@@ -1,5 +1,5 @@
---- src/gettext.h.orig 2008-10-07 12:01:37.000000000 -0400
-+++ src/gettext.h 2008-10-07 12:01:45.000000000 -0400
+--- a/src/gettext.h.orig 2008-10-07 12:01:37.000000000 -0400
++++ b/src/gettext.h 2008-10-07 12:01:45.000000000 -0400
@@ -24,6 +24,7 @@
/* Get declarations of GNU message catalog functions. */
diff --git a/games-arcade/xbubble/files/xbubble-0.5.8-png15.patch b/games-arcade/xbubble/files/xbubble-0.5.8-png15.patch
index 3a0a7d360efb..bbbae5c31076 100644
--- a/games-arcade/xbubble/files/xbubble-0.5.8-png15.patch
+++ b/games-arcade/xbubble/files/xbubble-0.5.8-png15.patch
@@ -1,5 +1,5 @@
---- src/loadpng.c.old 2011-09-14 09:58:40.503566961 +0200
-+++ src/loadpng.c 2011-09-14 10:03:39.708531447 +0200
+--- a/src/loadpng.c.old 2011-09-14 09:58:40.503566961 +0200
++++ b/src/loadpng.c 2011-09-14 10:03:39.708531447 +0200
@@ -73,7 +73,7 @@
return NULL;
}
diff --git a/games-arcade/xbubble/files/xbubble-0.5.8-xpaths.patch b/games-arcade/xbubble/files/xbubble-0.5.8-xpaths.patch
index c3dfa83cb5e3..4db0b8f10ccf 100644
--- a/games-arcade/xbubble/files/xbubble-0.5.8-xpaths.patch
+++ b/games-arcade/xbubble/files/xbubble-0.5.8-xpaths.patch
@@ -1,8 +1,8 @@
the x_libraries variable isnt always defined
http://bugs.gentoo.org/92688
---- configure
-+++ configure
+--- a/configure
++++ b/configure
@@ -4511,3 +4511,5 @@
fi
+if test x"$x_libraries" != x; then
diff --git a/games-arcade/xbubble/xbubble-0.5.8-r1.ebuild b/games-arcade/xbubble/xbubble-0.5.8-r1.ebuild
new file mode 100644
index 000000000000..67c8f575299f
--- /dev/null
+++ b/games-arcade/xbubble/xbubble-0.5.8-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="A Puzzle Bobble clone similar to Frozen-Bubble"
+HOMEPAGE="http://www.nongnu.org/xbubble/"
+SRC_URI="http://www.ibiblio.org/pub/mirrors/gnu/ftp/savannah/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXt
+ media-libs/libpng:0=
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS NetworkProtocol README TODO )
+
+src_prepare() {
+ default
+ eapply \
+ "${FILESDIR}"/${P}-xpaths.patch \
+ "${FILESDIR}"/${P}-locale.patch \
+ "${FILESDIR}"/${P}-libpng14.patch \
+ "${FILESDIR}"/${P}-png15.patch
+ sed -i \
+ -e '/^AM_CFLAGS/d' \
+ src/Makefile.in || die
+ sed -i \
+ -e '/^localedir/s:=.*:=/usr/share/locale:' \
+ configure po/Makefile.in.in || die
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ default
+ newicon data/themes/fancy/Bubble_black_DEAD_01.png ${PN}.png
+ make_desktop_entry ${PN} XBubble
+}