summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/fail/fail-4.9.0.0.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-haskell/fail/fail-4.9.0.0.ebuild b/dev-haskell/fail/fail-4.9.0.0.ebuild
index 01c2904253c0..f5bb54330f1d 100644
--- a/dev-haskell/fail/fail-4.9.0.0.ebuild
+++ b/dev-haskell/fail/fail-4.9.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -6,6 +6,9 @@ EAPI=5
# ebuild generated by hackport 0.4.7.9999
CABAL_FEATURES="lib profile" # ghc-8 already provides module; haddock hoogle hscolour"
+# break circular dependencies:
+# https://github.com/gentoo-haskell/gentoo-haskell/issues/810
+CABAL_FEATURES+=" nocabaldep"
inherit haskell-cabal
DESCRIPTION="Forward-compatible MonadFail class"
@@ -19,6 +22,4 @@ IUSE=""
RDEPEND=">=dev-lang/ghc-7.4.1:=
"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.10
-"
+DEPEND="${RDEPEND}"