summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/qtpass/Manifest2
-rw-r--r--app-admin/qtpass/qtpass-1.2.1.ebuild (renamed from app-admin/qtpass/qtpass-1.1.6.ebuild)10
-rw-r--r--app-admin/qtpass/qtpass-9999.ebuild40
3 files changed, 9 insertions, 43 deletions
diff --git a/app-admin/qtpass/Manifest b/app-admin/qtpass/Manifest
index 682876977ccf..397410986fb2 100644
--- a/app-admin/qtpass/Manifest
+++ b/app-admin/qtpass/Manifest
@@ -1 +1 @@
-DIST qtpass-1.1.6.tar.gz 325329 BLAKE2B 091cc00bc276f637a5d7f954a715a6e3687e1b369f1fd572f90c956c721524159a82d4283b025980f9b31132e07236706bd79fbbb830adccd3167a979bca48cc SHA512 64d712a33df97b04ab1a9d5472aa7fa567e38e31ff7ba297e567d087a3f32b1c59097b339cdd4f568efc2bce16b93f2d2316e94d2605b6abac299d7cf7d0c3df
+DIST qtpass-1.2.1.tar.gz 361147 BLAKE2B f46ce4362d4d3e0c0b0a425e5a40cf013181b899d5b1a2efc03cc5c4a3eca2d3ce1cdca78fdb95e8fecae23ffe56c01dbe65c9d07e2fff48934e995a710aac40 SHA512 3621a46aab5db5a41e80aea10bc6baf662510bcb249a1f56d33492aa66c824d9f018164f2d6a70256a7b3d59a9b73c4c8459b5d3fbe19886a607f8f0dc7410c1
diff --git a/app-admin/qtpass/qtpass-1.1.6.ebuild b/app-admin/qtpass/qtpass-1.2.1.ebuild
index 67195457fc95..dc949c150fc4 100644
--- a/app-admin/qtpass/qtpass-1.1.6.ebuild
+++ b/app-admin/qtpass/qtpass-1.2.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
MY_P="QtPass-${PV}"
-inherit qmake-utils
+inherit qmake-utils desktop
DESCRIPTION="multi-platform GUI for pass, the standard unix password manager"
HOMEPAGE="https://qtpass.org/"
@@ -27,6 +27,12 @@ RDEPEND="app-admin/pass
DEPEND="${RDEPEND}
dev-qt/linguist-tools:5"
+src_prepare() {
+ default
+
+ sed -i 's/SUBDIRS += src tests main/SUBDIRS += src main/' "${S}"/qtpass.pro || die
+ sed -i '/main\.depends = tests/d' "${S}"/qtpass.pro || die
+}
src_configure() {
eqmake5 PREFIX="${D}"/usr
}
diff --git a/app-admin/qtpass/qtpass-9999.ebuild b/app-admin/qtpass/qtpass-9999.ebuild
deleted file mode 100644
index 8da3eb46f11f..000000000000
--- a/app-admin/qtpass/qtpass-9999.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit qmake-utils git-r3
-
-DESCRIPTION="multi-platform GUI for pass, the standard unix password manager"
-HOMEPAGE="https://qtpass.org/"
-EGIT_REPO_URI="https://github.com/IJHack/${PN}.git"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-DOCS=( FAQ.md README.md CONTRIBUTING.md )
-
-RDEPEND="dev-qt/qtcore:5
- dev-qt/qtgui:5[xcb]
- dev-qt/qtwidgets:5
- dev-qt/qtnetwork:5
- app-admin/pass
- net-misc/x11-ssh-askpass"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
-"
-
-src_configure() {
- eqmake5 PREFIX="${D}"/usr
-}
-
-src_install() {
- default
-
- doman ${PN}.1
-
- insinto /usr/share/applications
- doins "${PN}.desktop"
-
- newicon artwork/icon.svg "${PN}-icon.svg"
-}