summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/hugo/Manifest2
-rw-r--r--www-apps/hugo/hugo-0.121.2.ebuild101
2 files changed, 103 insertions, 0 deletions
diff --git a/www-apps/hugo/Manifest b/www-apps/hugo/Manifest
index 0c31a795db44..ffcc40e6df21 100644
--- a/www-apps/hugo/Manifest
+++ b/www-apps/hugo/Manifest
@@ -2,3 +2,5 @@ DIST hugo-0.119.0-vendor.tar.xz 6642728 BLAKE2B 1a7c3d8acb895f01db97b8583d7d578b
DIST hugo-0.119.0.tar.gz 19579413 BLAKE2B f383f28b054fb78f1e8c972ec84d88fcbc6d8902dcdbe4acaaa081fea2c78247b5345faaec93c708fbcf71fee38a781a2c7c213f042568b3bd6b27e3618713d9 SHA512 ce77d60869173d18d46d91e4f23910c709ccabdf81976c1c96177a9fbad965a13a735fafce37f413a40a5af248510e49f8b2da86c1ba4291fb8b3941e91ee5ea
DIST hugo-0.121.0-vendor.tar.xz 6682060 BLAKE2B 7aabdd97eada6b83e0e7bebe632f7b465a6d87d376e555325e4309eeed7b286a6e4f7bcb1bdab1884328decb25ee1356b438df9fa1f07a6d85aad36fcd3f2f7b SHA512 c7688f7d32fa0b3fbbaffc154b025eda83b24dcbacff94188c80811692a091498e5e8107715e3b24e497ef56d4e9af843a4c5a4a42a6b28a79146ab2c44344b1
DIST hugo-0.121.0.tar.gz 21036266 BLAKE2B a924e2ad2fc4a5c690bf3bdd2e837add543119632f3055117a73455555bc78996b9f3eeb42c94694135a8f174aced72fea359ca39ca3ed76673b2284dc641d60 SHA512 99566167e74e1eda996ca54b0284a56a1bcd6c69f60d4461faa3bcca2f0c2d499b5e4de806a78576b5ec7691aa6d81fb66b6f088a25255fc9496d1f65d37d2ac
+DIST hugo-0.121.2-vendor.tar.xz 6683208 BLAKE2B d4be99aaf686c79cfda28c3ed4d1023b5012f57375835dfca0311761dfc2a47499dc5095d64d010c111a2e09dec92741e6b7bea0f81900749778c0a403c255c2 SHA512 c15d37d0b07cc57425b1be3fdcaf887e13b38e911b355691fae3ba505eed4041dd6fc8c28925d71a4f8fd89900b8d9da105aa489c72109826611aca36dcb88b7
+DIST hugo-0.121.2.tar.gz 21074668 BLAKE2B 06e42bcba49e9e2329ae1b76cc76caf2ac83e13f067533e07cd5471c064ecc402fb7cffaa21df4e20514d96bcfb7f16b4ff078ab23b84506a4ccfc423b21afca SHA512 717da396fa887995e455c1cc7cfc21c535583ba70cb90bcb15ea47e389aa636e9ffa4f66b28bf313f225579e40bc2864ef9da6ebf00d006b3a1ca68f38a47673
diff --git a/www-apps/hugo/hugo-0.121.2.ebuild b/www-apps/hugo/hugo-0.121.2.ebuild
new file mode 100644
index 000000000000..aafcddeff092
--- /dev/null
+++ b/www-apps/hugo/hugo-0.121.2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 2018-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module shell-completion
+
+DESCRIPTION="Fast static HTML and CSS website generator"
+HOMEPAGE="https://gohugo.io https://github.com/gohugoio/hugo"
+SRC_URI="
+ https://github.com/gohugoio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://tastytea.de/files/gentoo/${P}-vendor.tar.xz
+"
+
+# NOTE: To create the vendor tarball, run:
+# `go mod vendor && cd .. && tar -caf ${P}-vendor.tar.xz ${P}/vendor`
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0 Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+IUSE="doc +extended test"
+
+BDEPEND="
+ >=dev-lang/go-1.21.5
+ test? (
+ dev-python/docutils
+ dev-ruby/asciidoctor
+ virtual/pandoc
+ )
+"
+RDEPEND="
+ extended? (
+ dev-libs/libsass:=
+ >=media-libs/libwebp-1.3.2:=
+ )
+"
+DEPEND="${RDEPEND}"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.121.0-unbundle-libwebp-and-libsass.patch
+ "${FILESDIR}"/${PN}-0.118.2-skip-some-tests.patch
+)
+
+src_configure() {
+ export CGO_ENABLED=1
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export MY_BUILD_FLAGS="$(usev extended "-tags extended")"
+
+ default
+}
+
+src_prepare() {
+ # wants to run command that require network access
+ rm testscripts/commands/mod{,_vendor,__disable,_get,_get_u}.txt || die
+
+ default
+}
+
+src_compile() {
+ mkdir -pv bin || die
+ ego build -ldflags "-X github.com/gohugoio/hugo/common/hugo.vendorInfo=gentoo:${PVR}" \
+ ${MY_BUILD_FLAGS} -o "${S}/bin/hugo"
+
+ bin/hugo gen man --dir man || die
+
+ mkdir -pv completions || die
+ bin/hugo completion bash > completions/hugo || die
+ bin/hugo completion fish > completions/hugo.fish || die
+ bin/hugo completion zsh > completions/_hugo || die
+
+ if use doc ; then
+ bin/hugo gen doc --dir doc || die
+ fi
+}
+
+src_test() {
+ ego test "./..." ${MY_BUILD_FLAGS}
+}
+
+src_install() {
+ dobin bin/*
+ doman man/*
+
+ dobashcomp completions/${PN}
+ dofishcomp completions/${PN}.fish
+ dozshcomp completions/_${PN}
+
+ if use doc ; then
+ dodoc -r doc/*
+ fi
+}
+
+pkg_postinst() {
+ elog "the sass USE-flag was renamed to extended. the functionality is the" \
+ "same, except it also toggles the dependency on libwebp (for encoding)"
+}