summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/apparmor-utils/Manifest1
-rw-r--r--sys-apps/apparmor-utils/apparmor-utils-2.10.1.ebuild57
-rw-r--r--sys-apps/apparmor-utils/apparmor-utils-2.11.0.ebuild59
-rw-r--r--sys-apps/apparmor-utils/files/apparmor-utils-2.10-shebang.patch16
4 files changed, 0 insertions, 133 deletions
diff --git a/sys-apps/apparmor-utils/Manifest b/sys-apps/apparmor-utils/Manifest
index c564ea3a69cb..b3f6af574955 100644
--- a/sys-apps/apparmor-utils/Manifest
+++ b/sys-apps/apparmor-utils/Manifest
@@ -1,2 +1 @@
-DIST apparmor-2.10.1.tar.gz 4494037 SHA256 07a76f338304baadc4ad69d025fe000b1ab4779a251ae8f338afdc13ef1e0f24 SHA512 93992c25f77bb46389160df8324c811b4c2f0fad4b425902b30ce31d6e1f3a0efe6b359c6f8348ef646f8b527584e1f19eb4f46b27fb1ba742489ad09d171278 WHIRLPOOL d59d935db520d3c59bd0398727a1151b3280c2bf56e8f978c3595f50ff06cb70aaddc0313a7d16705b8eadeb2018aeef7ce585423c3a6ed7c34dfd4e06df9c25
DIST apparmor-2.11.0.tar.gz 5013297 SHA256 b1c489ea11e7771b8e6b181532cafbf9ebe6603e3cb00e2558f21b7a5bdd739a SHA512 86b33c1cbbd256028dd5fdfaddc764c225845acd19c833223fce5cdd6164f997fe010d7b642791f834a3417b4ea847d77175fdfd89ea99ab2111933790d42b55 WHIRLPOOL 2a3ca9a943694fba0f225cffc2bac3782545c0970b490189585a87cccf18047128eaab754e53003e03d535a5851a3198b0738a89c6547e88d081f6ad31f066d5
diff --git a/sys-apps/apparmor-utils/apparmor-utils-2.10.1.ebuild b/sys-apps/apparmor-utils/apparmor-utils-2.10.1.ebuild
deleted file mode 100644
index 626d63b71214..000000000000
--- a/sys-apps/apparmor-utils/apparmor-utils-2.10.1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-inherit perl-module python-r1 versionator
-
-DESCRIPTION="Additional userspace utils to assist with AppArmor profile management"
-HOMEPAGE="http://apparmor.net/"
-SRC_URI="https://launchpad.net/apparmor/$(get_version_component_range 1-2)/${PV}/+download/apparmor-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="dev-lang/perl
- ${PYTHON_DEPS}"
-RDEPEND="${DEPEND}
- ~sys-libs/libapparmor-${PV}[perl,python]
- ~sys-apps/apparmor-${PV}
- dev-perl/Locale-gettext
- dev-perl/RPC-XML
- dev-perl/TermReadKey
- virtual/perl-Data-Dumper
- virtual/perl-Getopt-Long"
-
-S=${WORKDIR}/apparmor-${PV}/utils
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.10-shebang.patch"
-)
-
-src_compile() {
- python_setup
-
- # launches non-make subprocesses causing "make jobserver unavailable"
- # error messages to appear in generated code
- emake -j1
-}
-
-src_install() {
- perl_set_version
- emake DESTDIR="${D}" PERLDIR="${D}/${VENDOR_LIB}/Immunix" \
- VIM_INSTALL_PATH="${D}/usr/share/vim/vimfiles/syntax" install
-
- install_python() {
- "${PYTHON}" "${S}"/python-tools-setup.py install --prefix=/usr \
- --root="${D}" --version="${PV}"
- }
-
- python_foreach_impl install_python
- python_replicate_script "${D}"/usr/bin/aa-easyprof "${D}"/usr/sbin/apparmor_status \
- "${D}"/usr/sbin/aa-{audit,autodep,cleanprof,complain,disable,enforce,genprof,logprof,mergeprof,status,unconfined}
-}
diff --git a/sys-apps/apparmor-utils/apparmor-utils-2.11.0.ebuild b/sys-apps/apparmor-utils/apparmor-utils-2.11.0.ebuild
deleted file mode 100644
index fbd4daeaa6e8..000000000000
--- a/sys-apps/apparmor-utils/apparmor-utils-2.11.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_4 )
-inherit perl-module python-r1 versionator
-
-MY_PV="$(get_version_component_range 1-2)"
-
-DESCRIPTION="Additional userspace utils to assist with AppArmor profile management"
-HOMEPAGE="http://apparmor.net/"
-SRC_URI="https://launchpad.net/apparmor/${MY_PV}/${MY_PV}/+download/apparmor-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="dev-lang/perl
- ${PYTHON_DEPS}"
-RDEPEND="${DEPEND}
- ~sys-libs/libapparmor-${PV}[perl,python]
- ~sys-apps/apparmor-${PV}
- dev-perl/Locale-gettext
- dev-perl/RPC-XML
- dev-perl/TermReadKey
- virtual/perl-Data-Dumper
- virtual/perl-Getopt-Long"
-
-S=${WORKDIR}/apparmor-${PV}/utils
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.10-shebang.patch"
-)
-
-src_compile() {
- python_setup
-
- # launches non-make subprocesses causing "make jobserver unavailable"
- # error messages to appear in generated code
- emake -j1
-}
-
-src_install() {
- perl_set_version
- emake DESTDIR="${D}" PERLDIR="${D}/${VENDOR_LIB}/Immunix" \
- VIM_INSTALL_PATH="${D}/usr/share/vim/vimfiles/syntax" install
-
- install_python() {
- "${PYTHON}" "${S}"/python-tools-setup.py install --prefix=/usr \
- --root="${D}" --version="${PV}"
- }
-
- python_foreach_impl install_python
- python_replicate_script "${D}"/usr/bin/aa-easyprof "${D}"/usr/sbin/apparmor_status \
- "${D}"/usr/sbin/aa-{audit,autodep,cleanprof,complain,disable,enforce,genprof,logprof,mergeprof,status,unconfined}
-}
diff --git a/sys-apps/apparmor-utils/files/apparmor-utils-2.10-shebang.patch b/sys-apps/apparmor-utils/files/apparmor-utils-2.10-shebang.patch
deleted file mode 100644
index 19b8892ee314..000000000000
--- a/sys-apps/apparmor-utils/files/apparmor-utils-2.10-shebang.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Avoid rewriting the shebang.
-
-The ebuild will take care of this when replicating the script for each of the
-supported python implementations.
-
---- a/python-tools-setup.py
-+++ b/python-tools-setup.py
-@@ -43,7 +43,7 @@
- f = prefix + s
- # If we have a defined python version, use it instead of the system
- # default
-- if 'PYTHON' in os.environ:
-+ if False:
- lines = open(os.path.basename(s)).readlines()
- lines[0] = '#! /usr/bin/env %s\n' % os.environ['PYTHON']
- open(f, 'w').write("".join(lines))