summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pycairo/Manifest1
-rw-r--r--dev-python/pycairo/pycairo-1.13.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pycairo/Manifest b/dev-python/pycairo/Manifest
index d081c0c7b8c7..dfa91c278191 100644
--- a/dev-python/pycairo/Manifest
+++ b/dev-python/pycairo/Manifest
@@ -1,2 +1,3 @@
DIST py2cairo-1.10.0.tar.bz2 402070 SHA256 d30439f06c2ec1a39e27464c6c828b6eface3b22ee17b2de05dc409e429a7431 SHA512 cb3d54de9af4134460ce731da8166a3127a642c8a2e6184109437ddec115cd55b8dd2413a5c81700277bfe2f22fcfe268db4f3ba0f7649751e85bb34295f79fc WHIRLPOOL 60b57d55b27f06acd62714ac6ad7973ab973d42995fb536ae800263a2e8c7451a24ccafd96fe30f5bfa26e1ae218934d4fafaafec3e9666a39b33c78672407e2
DIST pycairo-1.10.0.tar.bz2 246556 SHA256 9aa4078e7eb5be583aeabbe8d87172797717f95e8c4338f0d4a17b683a7253be SHA512 a03db6f04cea504985f390b0734042390f491f32ae2bee1299dabbafd369fde36bb506ebb941d22bbc11b0d008c4f758baeacf309a7336880529455092db829f WHIRLPOOL e779d56d67ef18bbd052d81acb38d8b610ca4bbf787f4b0e3982633de55ff54d6dfa3e5ce1957321fba09f0ec2d12ce12057335de9d5ff3f84c2bc0530415e76
+DIST pycairo-1.13.1.tar.gz 123690 SHA256 d8f58de67ddd01eda9e5112de57599b7d0154d71c9474821e98866c228794641 SHA512 705979aec5166d1e750ddf2938934edb18d5093e340d9e604a70dc02499ec478db7b0c84572f7ff287139c1b3982a31a254c36641123aee183b3053efe299d59 WHIRLPOOL 307e052d632a4591b67776b62ea173b647273151411bb8bfa9cc4d6dd066dbba30b3ea2bd1b066f6c91fe0a7275e76d1a6c0ebcb15c9113ab28a3ceec04e59fa
diff --git a/dev-python/pycairo/pycairo-1.13.1.ebuild b/dev-python/pycairo/pycairo-1.13.1.ebuild
new file mode 100644
index 000000000000..3686caad8774
--- /dev/null
+++ b/dev-python/pycairo/pycairo-1.13.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the cairo library"
+HOMEPAGE="https://www.cairographics.org/pycairo/ https://github.com/pygobject/pycairo"
+SRC_URI="https://github.com/pygobject/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples test xcb"
+
+# Note: xpyb is used as the C header, not Python modules
+RDEPEND="
+ >=x11-libs/cairo-1.12.0[svg,xcb?]
+"
+DEPEND="${RDEPEND}
+ xcb? ( $(python_gen_cond_dep '>=x11-libs/xpyb-1.3' 'python2*') )
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_compile() {
+ local enable_xpyb
+ [[ ${EPYTHON} == python2* ]] && enable_xpyb=$(usex xcb "--enable-xpyb" "")
+
+ esetup.py build ${enable_xpyb}
+}
+
+python_compile_all() {
+ use doc && emake -C docs
+}
+
+python_test() {
+ local enable_xpyb
+ [[ ${EPYTHON} == python2* ]] && enable_xpyb=$(usex xcb "--enable-xpyb" "")
+
+ esetup.py test ${enable_xpyb}
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/. )
+
+ if use examples; then
+ dodoc -r examples
+ fi
+
+ distutils-r1_python_install_all
+}