summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/ee/ee-1.5.2.ebuild1
-rw-r--r--app-editors/ee/files/ee-gcc-10.patch22
2 files changed, 23 insertions, 0 deletions
diff --git a/app-editors/ee/ee-1.5.2.ebuild b/app-editors/ee/ee-1.5.2.ebuild
index 832cb1b3e8fa..ad4bb78c8530 100644
--- a/app-editors/ee/ee-1.5.2.ebuild
+++ b/app-editors/ee/ee-1.5.2.ebuild
@@ -22,6 +22,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-init-location.patch
"${FILESDIR}"/${PN}-signal.patch
"${FILESDIR}"/${PN}-Wformat-security.patch
+ "${FILESDIR}"/${PN}-gcc-10.patch
)
DOCS=( Changes README.${PN} ${PN}.i18n.guide ${PN}.msg )
diff --git a/app-editors/ee/files/ee-gcc-10.patch b/app-editors/ee/files/ee-gcc-10.patch
new file mode 100644
index 000000000000..2577d76f25f6
--- /dev/null
+++ b/app-editors/ee/files/ee-gcc-10.patch
@@ -0,0 +1,22 @@
+--- a/new_curse.c
++++ b/new_curse.c
+@@ -83,6 +83,8 @@
+ #endif
+
+
++struct _line *top_of_win;
++
+ WINDOW *curscr;
+ static WINDOW *virtual_scr;
+ WINDOW *stdscr;
+--- a/new_curse.h
++++ b/new_curse.h
+@@ -161,7 +161,7 @@
+ int number;
+ };
+
+-struct _line *top_of_win;
++extern struct _line *top_of_win;
+
+ typedef struct WIND {
+ int SR; /* starting row */