summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2015.12.21.ebuild87
2 files changed, 0 insertions, 88 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index ed0f6f32b87f..e76994089574 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,4 +1,3 @@
DIST youtube-dl-2015.04.03.tar.gz 1472296 SHA256 0521a15a24a9b620728a2f45ea9163ca74660ed443781b6e69b4e06d36d7bf59 SHA512 6b2c85cfa222a31f3462aab583fa98bb92544cd5fb0d395ca0b69a26c24ab174870d02264e058281f09305752d50aa5a06d0d747205499a530b275e3194fc6f9 WHIRLPOOL 391e06ea261f92e03a0b38618307f1c9d53a2dfb9f2062fe0cd3ded1ea0c411033a17ded581616032c74a9e4fb398a57e565bf847196a23a9f89433f861362ae
-DIST youtube-dl-2015.12.21.tar.gz 1849071 SHA256 7a61ccbc3cd55e712b2fb94a7dedff5052548bbebab9f8c441feec8a02748d4d SHA512 36ad04ccd539a2c63d39e59444033e3eb8d9e2265b769869e54d598ec4a956e3ede939a23fad6531682d0166869b88fd728368a81064690af3f197a45b92b5aa WHIRLPOOL 561239e3c48e75f1e393961d78aeecc2a45058d56bb42ab07accac1d27793cba90a2729424c63f49c50cf9539f683eed069cbdb7ae2bbd45cf0433bc639660b2
DIST youtube-dl-2015.12.23.tar.gz 1850244 SHA256 fe7088979c78eb900c3db110a577866a01e1dd537cddda25258893f099fff9ba SHA512 e6ca9197b54972ee2a1518c6d76a05c96c0b556a1b0be96bd6fbcf0cccfae4d0555e0aa4c718c6132ca9cb7243f9758b5f28c80be231d702d12a6c32928fb39b WHIRLPOOL fd1dbdb741bc6674b881829b6103b886e0f379b7a5e4d2181f672d445a7a56ceffe6619f114486546e70db3a14b92c7f6ead57586a9d090da77e56d583350b27
DIST youtube-dl-2015.12.29.tar.gz 1863530 SHA256 4ff67c9cb65f36f0409dc2f35953fe1b66164512c06d46ebb345cb8a70e46208 SHA512 15bef247acca28f29c798bda8413155c8985e0f2ffc8be35ec539de95710747c2c6af4304286eebb21cb0d6932d4d0d51f5a0e581d479d9fec5dc930e01b7e6e WHIRLPOOL 2596183f3e3897790964703c2585299d094aa63f9be112549123e56ff9f0c4b2651749b9dd80f066e01d942cd0b884ce7717a3849d67c2d99d6234cb9034c957
diff --git a/net-misc/youtube-dl/youtube-dl-2015.12.21.ebuild b/net-misc/youtube-dl/youtube-dl-2015.12.21.ebuild
deleted file mode 100644
index 7c5ab5b4b433..000000000000
--- a/net-misc/youtube-dl/youtube-dl-2015.12.21.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
-DISTUTILS_SINGLE_IMPL=true
-inherit bash-completion-r1 distutils-r1 eutils
-
-DESCRIPTION="Download videos from YouTube.com (and more sites...)"
-HOMEPAGE="https://rg3.github.com/youtube-dl/"
-SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="offensive test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[coverage(+)] )
-"
-
-S="${WORKDIR}/${PN}"
-
-src_prepare() {
- if ! use offensive; then
- sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
- youtube_dl/version.py || die
- # these have single line import statements
- local xxx=(
- alphaporno anysex behindkink drtuber eporner eroprofile extremetube
- fourtube foxgay goshgay hellporno hentaistigma hornbunny keezmovies
- mofosex motherless porn91 pornhd pornotube pornovoisines pornoxo
- redtube sexykarma sexu sunporno slutload spankbang spankwire thisav
- trutube tube8 vporn xbef xnxx xtube xvideos xxxymovies youjizz
- youporn
- )
- # these have multi-line import statements
- local mxxx=(
- pornhub xhamster tnaflix
- )
- # do single line imports
- sed -i \
- -e $( printf '/%s/d;' ${xxx[@]} ) \
- youtube_dl/extractor/__init__.py \
- || die
-
- # do multiple line imports
- sed -i \
- -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
- youtube_dl/extractor/__init__.py \
- || die
-
- sed -i \
- -e $( printf '/%s/d;' ${mxxx[@]} ) \
- youtube_dl/extractor/generic.py \
- youtube_dl/extractor/tumblr.py \
- || die
-
- rm \
- $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
- $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
- test/test_age_restriction.py \
- || die
- fi
-
- epatch_user
-}
-
-src_compile() {
- distutils-r1_src_compile
-}
-
-src_test() {
- emake test
-}
-
-src_install() {
- python_domodule youtube_dl
- dobin bin/${PN}
- dodoc README.txt
- doman ${PN}.1
- newbashcomp ${PN}.bash-completion ${PN}
- python_fix_shebang "${ED}"
-}