summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/rocminfo/files/rocminfo-2.6.0-cmake-variables.patch31
-rw-r--r--dev-util/rocminfo/files/rocminfo-2.7.0-sizeof.patch23
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-util/rocminfo/files/rocminfo-2.6.0-cmake-variables.patch b/dev-util/rocminfo/files/rocminfo-2.6.0-cmake-variables.patch
deleted file mode 100644
index 1678f5043273..000000000000
--- a/dev-util/rocminfo/files/rocminfo-2.6.0-cmake-variables.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-https://github.com/RadeonOpenCompute/rocminfo/pull/17
-
-From c9bfc4b3db029b8502f900cd9bb545a675ca0898 Mon Sep 17 00:00:00 2001
-From: Craig Andrews <candrews@integralblue.com>
-Date: Thu, 25 Jul 2019 17:59:51 -0400
-Subject: [PATCH] Use CACHE variables, allow overriding
- ROCR_LIB_DIR/ROCR_INC_DIR
-
-CACHE variables allow for variables to be documented, and ROCR_LIB_DIR/ROCR_INC_DIR should be overridable as they'll have different values on different Linux distributions.
----
- CMakeLists.txt | 7 ++++---
- 1 file changed, 4 insertions(+), 3 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index b5fa9dd..f8f430f 100755
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -43,9 +43,10 @@ endif()
- #
-
- # Required Defines first:
--
--set(ROCR_INC_DIR ${ROCM_DIR}/include)
--set(ROCR_LIB_DIR ${ROCM_DIR}/lib)
-+set(ROCRTST_BLD_BITS CACHE "64" STRING "Either 32 or 64")
-+set(ROCM_DIR CACHE PATH "Root for RocM install")
-+set(ROCR_INC_DIR ${ROCM_DIR}/include CACHE PATH "Path for RocM includes")
-+set(ROCR_LIB_DIR ${ROCM_DIR}/lib CACHE PATH "Path for RocM libraries")
- #
- # Determine ROCR Header files are present
- #
diff --git a/dev-util/rocminfo/files/rocminfo-2.7.0-sizeof.patch b/dev-util/rocminfo/files/rocminfo-2.7.0-sizeof.patch
deleted file mode 100644
index 2d96bb227791..000000000000
--- a/dev-util/rocminfo/files/rocminfo-2.7.0-sizeof.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From cf96f42165fe76b98f653f979b4c182279dcac64 Mon Sep 17 00:00:00 2001
-From: Wilfried Holzke <gentoo@holzke.net>
-Date: Fri, 16 Aug 2019 22:04:52 +0200
-Subject: [PATCH] Fixed sizeof(err_val) to return the number of characters in
- the array
-
----
- rocminfo.cc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/rocminfo.cc b/rocminfo.cc
-index 9fddcfb..ee20da8 100755
---- a/rocminfo.cc
-+++ b/rocminfo.cc
-@@ -72,7 +72,7 @@
- char* err_str = NULL; \
- if (hsa_status_string(err, \
- (const char**)&err_str) != HSA_STATUS_SUCCESS) { \
-- snprintf(&(err_val[0]), sizeof(err_val[12]), "%#x", (uint32_t)err); \
-+ snprintf(&(err_val[0]), sizeof(err_val), "%#x", (uint32_t)err); \
- err_str = &(err_val[0]); \
- } \
- printf("%shsa api call failure at: %s:%d\n", \