summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-eselect/eselect-python/eselect-python-20140125-r1.ebuild47
-rw-r--r--app-eselect/eselect-python/files/eselect-python-20140125-pythonX.Y-config.patch38
2 files changed, 85 insertions, 0 deletions
diff --git a/app-eselect/eselect-python/eselect-python-20140125-r1.ebuild b/app-eselect/eselect-python/eselect-python-20140125-r1.ebuild
new file mode 100644
index 000000000000..7babd510f7d5
--- /dev/null
+++ b/app-eselect/eselect-python/eselect-python-20140125-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2
+ https://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="https://www.gentoo.org/proj/en/Python/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-1.2.3"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-pythonX.Y-config.patch
+ [[ ${PV} == "99999999" ]] && eautoreconf
+}
+
+src_install() {
+ keepdir /etc/env.d/python
+ emake DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ if has_version 'dev-lang/python'; then
+ eselect python update --if-unset
+ fi
+ if has_version '=dev-lang/python-2*'; then
+ eselect python update --python2 --if-unset
+ fi
+ if has_version '=dev-lang/python-3*'; then
+ eselect python update --python3 --if-unset
+ fi
+}
diff --git a/app-eselect/eselect-python/files/eselect-python-20140125-pythonX.Y-config.patch b/app-eselect/eselect-python/files/eselect-python-20140125-pythonX.Y-config.patch
new file mode 100644
index 000000000000..f35cd2c8f0df
--- /dev/null
+++ b/app-eselect/eselect-python/files/eselect-python-20140125-pythonX.Y-config.patch
@@ -0,0 +1,38 @@
+From 3a5909537315dbe624fbd242d8ab25f3926465fb Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sun, 28 Feb 2016 17:04:40 +0100
+Subject: [PATCH] Use pythonX.Y-config instead of python-config-X.Y
+
+---
+ python.eselect.in | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/python.eselect.in b/python.eselect.in
+index 9a52791..c40483a 100644
+--- a/python.eselect.in
++++ b/python.eselect.in
+@@ -46,9 +46,9 @@ set_python_config() {
+ #!/usr/bin/env bash
+ # Gentoo python-config wrapper script
+
+-[[ "\${EPYTHON}" =~ (/|^python\$) ]] && EPYTHON="${target/-config-/}"
+-python_config="\${EPYTHON/python/python-config-}"
+-"\${0%/*}/\${python_config:-${target}}" "\$@"
++[[ "\${EPYTHON}" =~ (/|^python\$|^$) ]] && EPYTHON="${target%-config}"
++python_config="\${EPYTHON}-config"
++"\${0%/*}/\${python_config}" "\$@"
+ EOF
+ chmod a+rx "${script}"
+ }
+@@ -121,7 +121,7 @@ set_scripts_and_symlinks() {
+ ln -nfs "${target}" "${target%.*}"
+ if [[ "${SET_MAIN_ACTIVE_PYTHON_INTERPRETER}" == "1" ]]; then
+ set_python "${target}"
+- set_python_config "${target/python/python-config-}"
++ set_python_config "${target}-config"
+ ln -nfs "${target/python/pydoc}" pydoc
+ # idle is optionally installed
+ if [[ -f "${target/python/idle}" ]]; then
+--
+2.7.2
+