summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-go/go-crypto/go-crypto-0_pre20160126.ebuild16
1 files changed, 15 insertions, 1 deletions
diff --git a/dev-go/go-crypto/go-crypto-0_pre20160126.ebuild b/dev-go/go-crypto/go-crypto-0_pre20160126.ebuild
index 799b98bf93b5..d02d1e914353 100644
--- a/dev-go/go-crypto/go-crypto-0_pre20160126.ebuild
+++ b/dev-go/go-crypto/go-crypto-0_pre20160126.ebuild
@@ -24,6 +24,20 @@ IUSE=""
DEPEND=""
RDEPEND=""
+src_prepare() {
+ # disable broken tests
+ sed -e 's:TestAgentForward(:_\0:' \
+ -i src/${EGO_SRC}/ssh/test/agent_unix_test.go || die
+ sed -e 's:TestRunCommandSuccess(:_\0:' \
+ -e 's:TestRunCommandStdin(:_\0:' \
+ -e 's:TestRunCommandStdinError(:_\0:' \
+ -e 's:TestRunCommandWeClosed(:_\0:' \
+ -e 's:TestFuncLargeRead(:_\0:' \
+ -e 's:TestKeyChange(:_\0:' \
+ -e 's:TestValidTerminalMode(:_\0:' \
+ -i src/${EGO_SRC}/ssh/test/session_test.go || die
+}
+
src_compile() {
# Create a writable GOROOT in order to avoid sandbox violations.
cp -sR "$(go env GOROOT)" "${T}/goroot" || die
@@ -38,5 +52,5 @@ src_compile() {
src_test() {
# Exclude $(get_golibdir_gopath) from GOPATH
- go test -v -work -x "${EGO_PN}"
+ go test -v -work -x "${EGO_PN}" || die
}