summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/file/file-5.39-r3.ebuild10
-rw-r--r--sys-apps/file/file-9999.ebuild10
2 files changed, 14 insertions, 6 deletions
diff --git a/sys-apps/file/file-5.39-r3.ebuild b/sys-apps/file/file-5.39-r3.ebuild
index c8425291ed78..d9f6397209d1 100644
--- a/sys-apps/file/file-5.39-r3.ebuild
+++ b/sys-apps/file/file-5.39-r3.ebuild
@@ -6,11 +6,11 @@ EAPI=7
PYTHON_COMPAT=( python3_{6..9} )
DISTUTILS_OPTIONAL=1
-inherit autotools distutils-r1 libtool toolchain-funcs multilib-minimal
+inherit distutils-r1 libtool toolchain-funcs multilib-minimal
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/glensc/file.git"
- inherit git-r3
+ inherit autotools git-r3
else
SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
@@ -44,7 +44,11 @@ PATCHES=(
src_prepare() {
default
- eautoreconf
+
+ if [[ ${PV} == 9999 ]]; then
+ eautoreconf
+ fi
+
elibtoolize
# don't let python README kill main README #60043
diff --git a/sys-apps/file/file-9999.ebuild b/sys-apps/file/file-9999.ebuild
index d28938772d6c..71c29604e7d5 100644
--- a/sys-apps/file/file-9999.ebuild
+++ b/sys-apps/file/file-9999.ebuild
@@ -6,11 +6,11 @@ EAPI=7
PYTHON_COMPAT=( python3_{6..9} )
DISTUTILS_OPTIONAL=1
-inherit autotools distutils-r1 libtool toolchain-funcs multilib-minimal
+inherit distutils-r1 libtool toolchain-funcs multilib-minimal
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/glensc/file.git"
- inherit git-r3
+ inherit autotools git-r3
else
SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
@@ -42,7 +42,11 @@ PATCHES=(
src_prepare() {
default
- eautoreconf
+
+ if [[ ${PV} == 9999 ]]; then
+ eautoreconf
+ fi
+
elibtoolize
# don't let python README kill main README #60043