summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/gphoto2/Manifest1
-rw-r--r--media-gfx/gphoto2/files/0001-Fix-unwanted-automagic-activation-of-aalib-support.patch37
-rw-r--r--media-gfx/gphoto2/gphoto2-2.5.20.ebuild57
3 files changed, 95 insertions, 0 deletions
diff --git a/media-gfx/gphoto2/Manifest b/media-gfx/gphoto2/Manifest
index 2c319362fd61..5c482014878c 100644
--- a/media-gfx/gphoto2/Manifest
+++ b/media-gfx/gphoto2/Manifest
@@ -1,2 +1,3 @@
DIST gphoto2-2.5.14.tar.bz2 784442 BLAKE2B 185bd0d18e0b8d280c0ec366738850bd1fe2d1405179700fe25678c04a88b2092820aa5f049bcc6f97c964b5875bd32e3f8c7c5240ef3a71f2af04d6bfdaadb9 SHA512 47cb0d212673c9c0dbc996e0a67191a307599c844293a67184bd1529d9e3b417e154c6de64f4563f6f7e599a1bd6b127266f85f5baa97bd7d86922405bf45331
DIST gphoto2-2.5.15.tar.bz2 790513 BLAKE2B e8a22d014ebd33f5e0976d72c5df8373e29106def5da575b69d21f2a58e9408c6ce399476135909e57111196d6e61ead953f66a00c9f440b7cf92e0da0f4a0f6 SHA512 46058a12a81379f3311911e103cf934b6eb616d7f81180615b385d01e855bf6ce998eb12811b9d032328ebed6acfc4456f3a383cfedb93c6967c9699654d4f40
+DIST gphoto2-2.5.20.tar.bz2 790065 BLAKE2B 6e10aa468696bc3eff51aaa3e886ad2373997f91597e42b33777ac56bf668f918c2fa0cb8b70eb8f7cb45507e67c9cfc3a46a7408449ad35cc3b743daf74859d SHA512 0350c38c264e5ba858ee14952fbf6ad271e7fef05e3f5f8eb3d45102099ae435fec63b09881efa99af60d4e086a9c2f69be92a7e49617643ab13146a5e4655f3
diff --git a/media-gfx/gphoto2/files/0001-Fix-unwanted-automagic-activation-of-aalib-support.patch b/media-gfx/gphoto2/files/0001-Fix-unwanted-automagic-activation-of-aalib-support.patch
new file mode 100644
index 000000000000..8e78578d71d1
--- /dev/null
+++ b/media-gfx/gphoto2/files/0001-Fix-unwanted-automagic-activation-of-aalib-support.patch
@@ -0,0 +1,37 @@
+From 45fb2a39195b5b31f61f376323ff78ab40940760 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sat, 8 Dec 2018 16:19:35 +0100
+Subject: [PATCH] Fix unwanted automagic activation of aalib support
+
+---
+ configure.ac | 7 +++----
+ 1 file changed, 3 insertions(+), 4 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index a6068c9..c19fed9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -306,8 +306,9 @@ aa_msg="no (http://www.sourceforge.net/projects/aa-project)"
+ try_aa=:
+ have_aa=false
+ AC_ARG_WITH([aalib],AS_HELP_STRING([--with-aalib],[Do use aalib for preview ASCII rendering]),[
+- if test x$withval = xyes; then
+- try_aa=:
++ if test x$withval = xno; then
++ try_aa=false
++ aa_msg="no (not requested)"
+ fi
+ ])
+ if $try_aa; then
+@@ -323,8 +324,6 @@ if $try_aa; then
+ AA_LIBS="-laa"
+ fi
+ ])
+-else
+- aa_msg="no (not requested)"
+ fi
+ AM_CONDITIONAL([HAVE_AA], [$have_aa])
+ AC_SUBST([AA_LIBS])
+--
+2.19.2
+
diff --git a/media-gfx/gphoto2/gphoto2-2.5.20.ebuild b/media-gfx/gphoto2/gphoto2-2.5.20.ebuild
new file mode 100644
index 000000000000..5470646b4f22
--- /dev/null
+++ b/media-gfx/gphoto2/gphoto2-2.5.20.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="Free, redistributable digital camera software application"
+HOMEPAGE="http://www.gphoto.org/"
+SRC_URI="mirror://sourceforge/gphoto/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="aalib exif ncurses nls readline"
+
+# aalib -> needs libjpeg
+RDEPEND="
+ dev-libs/popt
+ >=media-libs/libgphoto2-2.5.17:=[exif?]
+ aalib? (
+ media-libs/aalib
+ virtual/jpeg:0 )
+ exif? ( media-libs/libexif )
+ ncurses? ( dev-libs/cdk:0= )
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.14.1 )
+"
+
+PATCHES=(
+ # https://github.com/gphoto/gphoto2/pull/179
+ "${FILESDIR}"/0001-Fix-unwanted-automagic-activation-of-aalib-support.patch
+)
+
+src_prepare() {
+ default
+ if ! use exif ; then
+ # Remove tests that require EXIF to pass, bug 610024
+ rm "${S}"/tests/data/test0{35,36,37,40}* || die
+ fi
+ # Leave GCC debug builds under user control
+ sed -r '/(C|LD)FLAGS/ s/ -g( |")/\1/' \
+ -i configure{.ac,} || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with aalib) \
+ $(use_with aalib jpeg) \
+ $(use_with exif libexif auto) \
+ $(use_with ncurses cdk) \
+ $(use_enable nls) \
+ $(use_with readline)
+}