summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-tcltk/tclpython/tclpython-5.0.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-tcltk/tclpython/tclpython-5.0.ebuild b/dev-tcltk/tclpython/tclpython-5.0.ebuild
index e4a170a603e8..f7c6efb3ea78 100644
--- a/dev-tcltk/tclpython/tclpython-5.0.ebuild
+++ b/dev-tcltk/tclpython/tclpython-5.0.ebuild
@@ -25,7 +25,6 @@ RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
src_compile() {
- local PKG_NAME
if python_is_python3; then
PKG_NAME=tclpython3
else
@@ -34,6 +33,10 @@ src_compile() {
emake PKG_NAME=${PKG_NAME} CC=$(tc-getCC)
}
+src_test() {
+ emake PKG_NAME=${PKG_NAME} CC=$(tc-getCC) test
+}
+
src_install() {
if python_is_python3; then
insinto /usr/$(get_libdir)