summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/oauth2client/Manifest2
-rw-r--r--dev-python/oauth2client/oauth2client-2.1.0.ebuild45
-rw-r--r--dev-python/oauth2client/oauth2client-2.2.0.ebuild45
3 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/oauth2client/Manifest b/dev-python/oauth2client/Manifest
index bfe551d387c1..fcc8caedf8cc 100644
--- a/dev-python/oauth2client/Manifest
+++ b/dev-python/oauth2client/Manifest
@@ -5,3 +5,5 @@ DIST oauth2client-1.5.1.tar.gz 130237 SHA256 3e4ad7b3399cd9c4b8785acbbba2ca55eae
DIST oauth2client-1.5.2.tar.gz 131665 SHA256 b8df20b122e4f49a5fe5bc3c825d16015f5012c171c6c81eb4048e4d8c2ffee3 SHA512 15f10b52aa93fc10289658d5ff671a247e5c92c5ff2be424a04617fee1a3a82439b829b0f5dcb04e3e84802e02580e366e08356df7ec6e24563a530d2f6b1db5 WHIRLPOOL 00f3033359eceda12528ef4caffc0a9d7d6561919272fe98e09d2599114f07d9be42eb32a4038c155c621581f98ecc0eb516bcaa018d4376e30906dd4a0adfbc
DIST oauth2client-2.0.1.tar.gz 153127 SHA256 fa0357fca4ce431073ead236256347aafe3d368c16c5edaeba7f826b1b1d5fb6 SHA512 66179a604418a8aee9ca9dbfc5ad18356d5130a588e85f4dab3330feef194af2114bc2eb18ec625acf791938e4d7f78ee55284f45a67a48c775676697ce2b183 WHIRLPOOL bef0f7394cbeade328f74288bd602973a7828915ff616c7331d6c1910be02bc74a8e11062bd0602a2c4f1681d7d8c6558aecd695df3ef711f74ba81fad0b1ab3
DIST oauth2client-2.0.2.tar.gz 164190 SHA256 f1e7f1453714a3861ca0827959e507160ba065503f17d49f5a84c5eb47b86514 SHA512 ef8c81fe7f0d254c71a15115be58787bbf771b824e988b56ba9561c58b4726b03b4fce1b8c8f50c971236c558b0205fff11b949f7b70fcf749f3eb210c8dab0b WHIRLPOOL 5958b658e8af39ee7789b268b1d091489bbd1aa08bf5ede58c49492e05092e25a9907b594238e54526dabfa5acfcfe024f9926bbb9ec52cb975766b4e34847c9
+DIST oauth2client-2.1.0.tar.gz 166673 SHA256 2c9f26468ea56c2e223b01224558f807d8645a2f1d5792b5b50f99e442827e19 SHA512 9db47b332c8a79f080b339fc7145fd8c5864c179032cbd703e0f236cc87412e015d2590ee22d031257d0003b09b3165e27c22a52bb789686613426104eb42cc7 WHIRLPOOL 87f36695cd0d37292f7544a258f6f38693a01351b1076e58dea2e9336a2691dd44d99663d94c124565407ec3727bf5cd86c031915bc170e79bb3d7805b271337
+DIST oauth2client-2.2.0.tar.gz 167484 SHA256 07b44748059d6390ce2247195b2ae2117773617614f76ec9375e56fd43295f06 SHA512 1e23c3f655e955dbf0cdb2b78613768ca4c6eb4336b555e3553da212fd762ba12329584f108d8145810228cf44da018675b38dd152b06e58be4eb18d4f8127c6 WHIRLPOOL 6cb1b3a6dbc4d3e0fca8d72417810873f11428afb4d4f52b08f7028c984bd330acf043ca10c339453c6f4e38c1f179c2e9126a9f6cb419323a53cbc769ebbe8f
diff --git a/dev-python/oauth2client/oauth2client-2.1.0.ebuild b/dev-python/oauth2client/oauth2client-2.1.0.ebuild
new file mode 100644
index 000000000000..f0ad4130a109
--- /dev/null
+++ b/dev-python/oauth2client/oauth2client-2.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="Library for accessing resources protected by OAuth 2.0"
+HOMEPAGE="https://github.com/google/oauth2client"
+SRC_URI="https://github.com/google/oauth2client/archive/v${PV/_p/-post}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.0.5[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+ !<=dev-python/google-api-python-client-1.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+S="${WORKDIR}"/${P/_p/-post}
+
+# Needs network
+RESTRICT=test
+
+python_prepare_all() {
+ sed -i \
+ -e "s:find_packages():find_packages(exclude=['tests','tests.*']):" \
+ setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests || die
+}
diff --git a/dev-python/oauth2client/oauth2client-2.2.0.ebuild b/dev-python/oauth2client/oauth2client-2.2.0.ebuild
new file mode 100644
index 000000000000..f0ad4130a109
--- /dev/null
+++ b/dev-python/oauth2client/oauth2client-2.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="Library for accessing resources protected by OAuth 2.0"
+HOMEPAGE="https://github.com/google/oauth2client"
+SRC_URI="https://github.com/google/oauth2client/archive/v${PV/_p/-post}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.0.5[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+ !<=dev-python/google-api-python-client-1.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+S="${WORKDIR}"/${P/_p/-post}
+
+# Needs network
+RESTRICT=test
+
+python_prepare_all() {
+ sed -i \
+ -e "s:find_packages():find_packages(exclude=['tests','tests.*']):" \
+ setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests || die
+}