summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-portage/pfl/pfl-3.0.1-r1.ebuild48
-rw-r--r--app-portage/pfl/pfl-3.0.1.ebuild44
2 files changed, 0 insertions, 92 deletions
diff --git a/app-portage/pfl/pfl-3.0.1-r1.ebuild b/app-portage/pfl/pfl-3.0.1-r1.ebuild
deleted file mode 100644
index e766bbbfde0a..000000000000
--- a/app-portage/pfl/pfl-3.0.1-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{5,6} )
-PYTHON_REQ_USE="xml"
-
-inherit distutils-r1
-
-DESCRIPTION="Searchable online file/package database for Gentoo"
-HOMEPAGE="http://www.portagefilelist.de"
-SRC_URI="https://dev.gentoo.org/~billie/distfiles/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="+network-cron"
-
-DEPEND=""
-RDEPEND="
- ${DEPEND}
- net-misc/curl
- sys-apps/portage[${PYTHON_USEDEP}]
- >=dev-python/ssl-fetch-0.4[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}/e-file-function.patch"
-)
-
-python_install_all() {
- if use network-cron ; then
- exeinto /etc/cron.weekly
- doexe cron/pfl
- fi
-
- keepdir /var/lib/${PN}
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- if [[ ! -e "${EROOT}/var/lib/${PN}/pfl.info" ]]; then
- touch "${EROOT}/var/lib/${PN}/pfl.info" || die
- fi
- chown -R portage:portage "${EROOT}/var/lib/${PN}" || die
- chmod 775 "${EROOT}/var/lib/${PN}" || die
-}
diff --git a/app-portage/pfl/pfl-3.0.1.ebuild b/app-portage/pfl/pfl-3.0.1.ebuild
deleted file mode 100644
index 9e577b97b8c4..000000000000
--- a/app-portage/pfl/pfl-3.0.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{5,6} )
-PYTHON_REQ_USE="xml"
-
-inherit distutils-r1
-
-DESCRIPTION="Searchable online file/package database for Gentoo"
-HOMEPAGE="http://www.portagefilelist.de"
-SRC_URI="https://dev.gentoo.org/~billie/distfiles/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="+network-cron"
-
-DEPEND=""
-RDEPEND="
- ${DEPEND}
- net-misc/curl
- sys-apps/portage[${PYTHON_USEDEP}]
- >=dev-python/ssl-fetch-0.4[${PYTHON_USEDEP}]
-"
-
-python_install_all() {
- if use network-cron ; then
- exeinto /etc/cron.weekly
- doexe cron/pfl
- fi
-
- keepdir /var/lib/${PN}
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- if [[ ! -e "${EROOT}/var/lib/${PN}/pfl.info" ]]; then
- touch "${EROOT}/var/lib/${PN}/pfl.info" || die
- fi
- chown -R portage:portage "${EROOT}/var/lib/${PN}" || die
- chmod 775 "${EROOT}/var/lib/${PN}" || die
-}