summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/logstash-bin/files/logstash.confd2
-rw-r--r--app-admin/logstash-bin/files/logstash.initd33
-rw-r--r--app-admin/logstash-bin/logstash-bin-1.4.5.ebuild50
-rw-r--r--app-admin/logstash-bin/logstash-bin-1.5.4.ebuild53
4 files changed, 0 insertions, 138 deletions
diff --git a/app-admin/logstash-bin/files/logstash.confd b/app-admin/logstash-bin/files/logstash.confd
deleted file mode 100644
index 29f4d1c016ae..000000000000
--- a/app-admin/logstash-bin/files/logstash.confd
+++ /dev/null
@@ -1,2 +0,0 @@
-#LOGSTASH_USER=""
-#LOGSTASH_GROUP=""
diff --git a/app-admin/logstash-bin/files/logstash.initd b/app-admin/logstash-bin/files/logstash.initd
deleted file mode 100644
index 08b063fe7044..000000000000
--- a/app-admin/logstash-bin/files/logstash.initd
+++ /dev/null
@@ -1,33 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-LOGSTASH_USER=${LOGSTASH_USER:-root}
-LOGSTASH_GROUP=${LOGSTASH_GROUP:-root}
-LOGFILE="/var/log/logstash/logstash.log"
-
-command="/opt/logstash/bin/logstash"
-command_args="agent --config /etc/logstash/conf.d/*.conf --log ${LOGFILE}"
-extra_commands="checkconfig"
-command_background="true"
-start_stop_daemon_args="--user=\"${LOGSTASH_USER}\""
-pidfile="/run/logstash/logstash.pid"
-
-depend() {
- use net
- after elasticsearch
-}
-
-checkconfig() {
- ebegin "Checking your configuration"
- ${command} ${command_args} --configtest
- eend $? "Configuration error. Please fix your configuration files."
-}
-
-start_pre() {
- checkconfig || return 1
-
- checkpath -d -o "${LOGSTASH_USER}":"${LOGSTASH_GROUP}" -m750 "$(dirname "${pidfile}")"
- checkpath -d -o "${LOGSTASH_USER}":"${LOGSTASH_GROUP}" -m750 "$(dirname "${LOGFILE}")"
- checkpath -f -o "${LOGSTASH_USER}":"${LOGSTASH_GROUP}" -m640 "${LOGFILE}"
-}
diff --git a/app-admin/logstash-bin/logstash-bin-1.4.5.ebuild b/app-admin/logstash-bin/logstash-bin-1.4.5.ebuild
deleted file mode 100644
index 027faae0d39d..000000000000
--- a/app-admin/logstash-bin/logstash-bin-1.4.5.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-MY_PN="${PN/-bin}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Tool for managing events and logs"
-HOMEPAGE="https://www.elastic.co/products/logstash"
-SRC_URI="https://download.elastic.co/${MY_PN}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND=""
-RDEPEND="|| ( virtual/jre:1.8 virtual/jre:1.7 )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_install() {
- keepdir /etc/"${MY_PN}"/{conf.d,patterns,plugins}
- keepdir "/var/log/${MY_PN}"
-
- insinto "/etc/${MY_PN}/conf.d"
- doins "${FILESDIR}/agent.conf.sample"
-
- insinto "/opt/${MY_PN}"
- doins -r .
- fperms 0755 "/opt/${MY_PN}/bin/${MY_PN}"
-
- insinto /etc/logrotate.d
- doins "${FILESDIR}/${MY_PN}.logrotate"
-
- newconfd "${FILESDIR}/${MY_PN}.confd" "${MY_PN}"
- newinitd "${FILESDIR}/${MY_PN}.initd" "${MY_PN}"
-}
-
-pkg_postinst() {
- einfo "Getting started with logstash:"
- einfo " https://www.elastic.co/guide/en/logstash/current/getting-started-with-logstash.html"
- einfo ""
- einfo "Packages that might be interesting:"
- einfo " app-misc/elasticsearch"
- einfo " dev-python/elasticsearch-curator"
- einfo " www-apps/kibana-bin"
-}
diff --git a/app-admin/logstash-bin/logstash-bin-1.5.4.ebuild b/app-admin/logstash-bin/logstash-bin-1.5.4.ebuild
deleted file mode 100644
index 18df7a31ce3f..000000000000
--- a/app-admin/logstash-bin/logstash-bin-1.5.4.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-MY_PN="${PN/-bin}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Tool for managing events and logs"
-HOMEPAGE="https://www.elastic.co/products/logstash"
-SRC_URI="https://download.elastic.co/${MY_PN}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-RESTRICT="strip"
-QA_PREBUILT="opt/logstash/vendor/jruby/lib/jni/*/libjffi*.so"
-
-DEPEND=""
-RDEPEND="|| ( virtual/jre:1.8 virtual/jre:1.7 )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_install() {
- keepdir /etc/"${MY_PN}"/{conf.d,patterns,plugins}
- keepdir "/var/log/${MY_PN}"
-
- insinto "/etc/${MY_PN}/conf.d"
- doins "${FILESDIR}/agent.conf.sample"
-
- insinto "/opt/${MY_PN}"
- doins -r .
- fperms 0755 "/opt/${MY_PN}/bin/${MY_PN}" "/opt/${MY_PN}/vendor/jruby/bin/jruby"
-
- insinto /etc/logrotate.d
- doins "${FILESDIR}/${MY_PN}.logrotate"
-
- newconfd "${FILESDIR}/${MY_PN}.confd" "${MY_PN}"
- newinitd "${FILESDIR}/${MY_PN}.initd" "${MY_PN}"
-}
-
-pkg_postinst() {
- einfo "Getting started with logstash:"
- einfo " https://www.elastic.co/guide/en/logstash/current/getting-started-with-logstash.html"
- einfo ""
- einfo "Packages that might be interesting:"
- einfo " app-misc/elasticsearch"
- einfo " dev-python/elasticsearch-curator"
- einfo " www-apps/kibana-bin"
-}