summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/uuagc/metadata.xml1
-rw-r--r--dev-haskell/uuagc/uuagc-0.9.52.1.ebuild11
2 files changed, 6 insertions, 6 deletions
diff --git a/dev-haskell/uuagc/metadata.xml b/dev-haskell/uuagc/metadata.xml
index 14528f8d181e..dd049f92501f 100644
--- a/dev-haskell/uuagc/metadata.xml
+++ b/dev-haskell/uuagc/metadata.xml
@@ -6,7 +6,6 @@
<name>Gentoo Haskell</name>
</maintainer>
<use>
- <flag name="bootstrap_external">Use an external uuagc executable for bootstrapping.</flag>
<flag name="with-loag">Use <pkg>dev-haskell/minisat</pkg> external SAT-solver to schedule all Linear Ordered AGs.</flag>
</use>
<longdescription>
diff --git a/dev-haskell/uuagc/uuagc-0.9.52.1.ebuild b/dev-haskell/uuagc/uuagc-0.9.52.1.ebuild
index ec27cc7c0ffd..7468cdca24dd 100644
--- a/dev-haskell/uuagc/uuagc-0.9.52.1.ebuild
+++ b/dev-haskell/uuagc/uuagc-0.9.52.1.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-# ebuild generated by hackport 0.4.4.9999
+# ebuild generated by hackport 0.5.5.9999
+#hackport: flags: -bootstrap_external
-CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Attribute Grammar System of Universiteit Utrecht"
@@ -15,7 +16,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE="bootstrap_external with-loag"
+IUSE="with-loag"
RDEPEND=">=dev-haskell/haskell-src-exts-1.11.1:=[profile?]
>=dev-haskell/mtl-1.1.1.1:=[profile?]
@@ -30,6 +31,6 @@ DEPEND="${RDEPEND}
src_configure() {
haskell-cabal_src_configure \
- $(cabal_flag bootstrap_external bootstrap_external) \
+ --flag=-bootstrap_external \
$(cabal_flag with-loag with-loag)
}