summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/branca/Manifest1
-rw-r--r--sci-libs/branca/branca-0.6.0.ebuild30
-rw-r--r--sci-libs/branca/files/branca-0.6.0-test.patch12
3 files changed, 43 insertions, 0 deletions
diff --git a/sci-libs/branca/Manifest b/sci-libs/branca/Manifest
index ee2664a83179..f32997db6a07 100644
--- a/sci-libs/branca/Manifest
+++ b/sci-libs/branca/Manifest
@@ -1 +1,2 @@
DIST branca-0.4.2.tar.gz 59337 BLAKE2B 7d7f101a3dcc07c0210f968da2ed41f4a75177b625ce46252024da7dbba82618dbe60886c615c9461c724af76b45c7710f631bc65d5743cee7f18a2052f9db49 SHA512 cefb3b0f41d515492902ef4046cf7f10b638aca8409f5b08f201550ed5a971a441d13243b1ce38ac0b8c0f76cde1329955d26c1856e1f3c25014a6ce0d805fd6
+DIST branca-0.6.0.tar.gz 40167 BLAKE2B 23cbe442862e9575d84dfb5bb1760acf2a1301be0f68bedc9965d9d3a8be090755f78640ed919b5ba8521ab30e8c52c69ea87ff2772d9fd6b3e338680b5219bb SHA512 e80b3d173bc487857ab42d10365540e91cb6fc5def61bb76f418e2da8e74c9bf69e0ca46f86a47f96f5db48d0e98d6ad3091107dd1a5ca479c52adbfa3a79a9c
diff --git a/sci-libs/branca/branca-0.6.0.ebuild b/sci-libs/branca/branca-0.6.0.ebuild
new file mode 100644
index 000000000000..edbdf573dee9
--- /dev/null
+++ b/sci-libs/branca/branca-0.6.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9..10} )
+DISTUTILS_USE_PEP517=setuptools
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+inherit distutils-r1
+
+DESCRIPTION="spinoff from folium, host the non-map-specific features"
+HOMEPAGE="https://github.com/python-visualization/branca"
+SRC_URI="https://github.com/python-visualization/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}"/${P}-test.patch )
+
+RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/selenium[${PYTHON_USEDEP}] )"
+BDEPEND=""
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -m 'not headless'
+}
diff --git a/sci-libs/branca/files/branca-0.6.0-test.patch b/sci-libs/branca/files/branca-0.6.0-test.patch
new file mode 100644
index 000000000000..e00b8a6cfc57
--- /dev/null
+++ b/sci-libs/branca/files/branca-0.6.0-test.patch
@@ -0,0 +1,12 @@
+--- a/setup.cfg 2023-02-09 09:15:07.186333281 +0100
++++ b/setup.cfg 2023-02-09 09:15:17.596181143 +0100
+@@ -1,9 +1,4 @@
+ [tool:pytest]
+-flake8-max-line-length = 105
+-flake8-ignore =
+- docs/* ALL
+- versioneer.py ALL
+- branca/_version.py ALL
+ markers =
+ headless: mark headless tests (deselect with '-m "not headless"')
+