summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/boost-build/Manifest1
-rw-r--r--dev-util/boost-build/boost-build-1.63.0.ebuild140
2 files changed, 0 insertions, 141 deletions
diff --git a/dev-util/boost-build/Manifest b/dev-util/boost-build/Manifest
index 2b2ef1bcd319..46bae38d9768 100644
--- a/dev-util/boost-build/Manifest
+++ b/dev-util/boost-build/Manifest
@@ -1,4 +1,3 @@
-DIST boost_1_63_0.tar.bz2 81984414 BLAKE2B 227c4432bd3ca0eb390048ec85047958fcb6ae289996501812cd8b13bf74bbe9b677d0110948265cab59a60deb36c4fc08440af74ac5a5219ea4eaea4fa6918f SHA512 c915c5f5778dee49b8e9d0a40f37f90f56fb1fdb1d8ce92d97bf48bc7bc462212487badfe4bbe30b06196d1149cfb221da12ac54e97499b0d4cb6466813bb4ad
DIST boost_1_65_0.tar.bz2 82597718 BLAKE2B 0080956d6ad2f14130ce4a4734b1bd1ce83d3651b226653689e02770baa83cf11811ef4e44948ff68a168d9ce5cbfaea4f758970df2b4e9faa2d410181885f5b SHA512 7142650fb8d61e3ef16ba066fc918e087f19e9bc2ad1d6a11fb10bf0d6b1b5ad05ab032f076a5233a1624b3669e952b2cc38b7dc074bbf53018e2970ee90fcdd
DIST boost_1_66_0.tar.bz2 85995778 BLAKE2B 9ab1fe396b10ab85d7e4084ec7abb8d785ecd892c8f51aea5a401cb565b111c256533364fe028da74ed376534889f43c5ccbdcd703cd236526ae66a064220765 SHA512 0f34075d35391d66876e5189a01a11880a79428e1b267456348ee148dba9dc3abdc74d568f1853be631d20b584b1c804b42443c266f7622164acfc10be3dab8b
DIST boost_1_67_0.tar.bz2 87336566 BLAKE2B 85ea00fc2197b1bbfc35d69427c87f23ea43d7592f1c9ce66e2afcde8476bdec86f6debdac815b23de59f4665a8e0c7f1519ab66a31d39df629723bc45710058 SHA512 82bf33d7d2c3db109c9d1f12d40bc2d364c8c95262386f906ccd1a71cd71433bcc01829e968b4a13a5003cf0b50cbdf0b435a1d76530cea7bb05725c327411e8
diff --git a/dev-util/boost-build/boost-build-1.63.0.ebuild b/dev-util/boost-build/boost-build-1.63.0.ebuild
deleted file mode 100644
index 4dbc423b5357..000000000000
--- a/dev-util/boost-build/boost-build-1.63.0.ebuild
+++ /dev/null
@@ -1,140 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-RESTRICT="test"
-
-PYTHON_COMPAT=( python2_7 )
-inherit eutils flag-o-matic python-single-r1 toolchain-funcs versionator
-
-MY_PV="$(replace_all_version_separators _)"
-
-DESCRIPTION="A system for large project software construction, simple to use and powerful"
-HOMEPAGE="https://boostorg.github.io/build/"
-SRC_URI="https://downloads.sourceforge.net/project/boost/boost/${PV}/boost_${MY_PV}.tar.bz2"
-
-LICENSE="Boost-1.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="examples python test"
-
-RDEPEND="python? ( ${PYTHON_DEPS} )
- !<dev-libs/boost-1.34.0
- !<=dev-util/boost-build-1.35.0-r1"
-DEPEND="${RDEPEND}
- test? ( sys-apps/diffutils
- ${PYTHON_DEPS} )"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
- test? ( ${PYTHON_REQUIRED_USE} )"
-
-S="${WORKDIR}/boost_${MY_PV}/tools/build/src"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.48.0-disable_python_rpath.patch"
- "${FILESDIR}/${PN}-1.50.0-respect-c_ld-flags.patch"
- "${FILESDIR}/${PN}-1.49.0-darwin-gentoo-toolchain.patch"
- "${FILESDIR}/${PN}-1.52.0-darwin-no-python-framework.patch"
- "${FILESDIR}/${PN}-1.54.0-support_dots_in_python-buildid.patch"
- "${FILESDIR}/${PN}-1.55.0-ppc-aix.patch"
- "${FILESDIR}/${PN}-1.62.0-sparc-no-default-flags.patch"
-)
-
-pkg_setup() {
- if use python || use test; then
- python-single-r1_pkg_setup
- fi
-}
-
-src_unpack() {
- tar xojf "${DISTDIR}/${A}" boost_${MY_PV}/tools/build || die "unpacking tar failed"
-}
-
-src_prepare() {
- default
-
- pushd ../ >/dev/null || die
- eapply "${FILESDIR}/${PN}-1.54.0-fix-test.patch"
- popd >/dev/null || die
-
- # Remove stripping option
- # Fix python components build on multilib systems, bug #496446
- cd "${S}/engine" || die
- sed -i \
- -e 's|-s\b||' \
- -e "/libpython/s/lib ]/$(get_libdir) ]/" \
- build.jam || die "sed failed"
-
- # Force regeneration
- rm jambase.c || die
-
- # This patch allows us to fully control optimization
- # and stripping flags when bjam is used as build-system
- # We simply extend the optimization and debug-symbols feature
- # with empty dummies called 'none'
- cd "${S}" || die
- sed -i \
- -e 's/\(off speed space\)/\1 none/' \
- -e 's/\(debug-symbols : on off\)/\1 none/' \
- tools/builtin.jam || die "sed failed"
-}
-
-src_configure() {
- if use python; then
- # replace versions by user-selected one (TODO: fix this when slot-op
- # deps are available to always match the best version available)
- sed -i \
- -e "s|27 26 25 24 23 22|${EPYTHON#python}|" \
- engine/build.jam || die "sed failed"
- fi
-}
-
-src_compile() {
- cd engine || die
-
- local toolset
-
- if [[ ${CHOST} == *-darwin* ]]; then
- toolset=darwin
- else
- # Using boost's generic toolset here, which respects CC and CFLAGS
- toolset=cc
- fi
-
- CC=$(tc-getCC) ./build.sh ${toolset} -d+2 $(use_with python python "${EROOT%/}"/usr) || die "building bjam failed"
-}
-
-src_install() {
- dobin engine/bin.*/{bjam,b2}
-
- insinto /usr/share/boost-build
- doins -r "${FILESDIR}/site-config.jam" \
- ../boost-build.jam bootstrap.jam build-system.jam ../example/user-config.jam *.py \
- build kernel options tools util
-
- if ! use python; then
- find "${ED%/}/usr/share/boost-build" -iname "*.py" -delete || die "removing experimental python files failed"
- fi
-
- dodoc ../notes/{changes,release_procedure,build_dir_option,relative_source_paths}.txt
-
- if use examples; then
- docinto examples
- dodoc -r ../example/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
-
-src_test() {
- cd ../test || die
-
- export TMP="${T}"
-
- DO_DIFF="${PREFIX}/usr/bin/diff" ${PYTHON} test_all.py
-
- if [[ -s test_results.txt ]]; then
- eerror "At least one test failed: $(<test_results.txt)"
- die "tests failed"
- fi
-}