summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gui-apps/wcm/Manifest1
-rw-r--r--gui-apps/wcm/wcm-0.5.0.ebuild34
-rw-r--r--gui-apps/wf-shell/Manifest1
-rw-r--r--gui-apps/wf-shell/wf-shell-0.5.0.ebuild43
-rw-r--r--gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.7.0.ebuild5
-rw-r--r--gui-libs/wf-config/Manifest2
-rw-r--r--gui-libs/wf-config/wf-config-0.5.0.ebuild34
-rw-r--r--gui-libs/wf-config/wf-config-0.7.0.ebuild34
-rw-r--r--gui-wm/wayfire/Manifest2
-rw-r--r--gui-wm/wayfire/wayfire-0.5.0.ebuild92
-rw-r--r--gui-wm/wayfire/wayfire-0.7.0.ebuild98
11 files changed, 3 insertions, 343 deletions
diff --git a/gui-apps/wcm/Manifest b/gui-apps/wcm/Manifest
index da9e68f870a5..ae75d377f434 100644
--- a/gui-apps/wcm/Manifest
+++ b/gui-apps/wcm/Manifest
@@ -1,2 +1 @@
-DIST wcm-0.5.0.tar.gz 253120 BLAKE2B 44f6e36425ed070f086fcea6b3374b8fd2f1e3420176098699ec735cb74a1de0d6919ca71e62ca61116005ad26e50562e0a927dce7990d87eb7559511fb371e3 SHA512 c06e97fa3b22f33bb7f05efda380484377596cce83b7874d42b6f3795f275faee2fdd2f2a6a6f24ebbb7e339a0dd3e526a3d02a2e1d4c45b34f76d627896bc53
DIST wcm-0.7.0.tar.xz 263952 BLAKE2B 6e8761b75d5e37e49a1ba1e9b2a045c7350fa28642d26f1f66b0513fdb4130495f43bcae137184bf5bd2f0f2a0d5a81891459819d692a84b66b96c7d1440ee7e SHA512 190d8befafac69c27d99d10113160a1806a9dbd83f740216dd38e9cbe3c2638817b3471c9f46b60642e91abe02fbb72458b61f07bda9cd5fc5dbc7cdf880c6bb
diff --git a/gui-apps/wcm/wcm-0.5.0.ebuild b/gui-apps/wcm/wcm-0.5.0.ebuild
deleted file mode 100644
index f1467516605b..000000000000
--- a/gui-apps/wcm/wcm-0.5.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="Wayfire Config Manager"
-HOMEPAGE="https://github.com/WayfireWM/wcm"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/WayfireWM/wcm.git"
-else
- SRC_URI="https://github.com/WayfireWM/wcm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-DEPEND="
- dev-libs/libevdev
- dev-libs/libxml2
- dev-cpp/gtkmm:3.0[wayland]
- >=gui-wm/wayfire-${PV}
-"
-
-RDEPEND="${DEPEND}"
-
-BDEPEND="
- dev-libs/wayland-protocols
- virtual/pkgconfig
-"
diff --git a/gui-apps/wf-shell/Manifest b/gui-apps/wf-shell/Manifest
index fff0d4674437..50a3e27f9293 100644
--- a/gui-apps/wf-shell/Manifest
+++ b/gui-apps/wf-shell/Manifest
@@ -1,2 +1 @@
-DIST wf-shell-0.5.0.tar.xz 8998296 BLAKE2B c32232fc08292b15a0048d11d0f179a82fd21b3179223d898057ac95b42ac35ec063467f67c0f1261857c3b643edc4367112a05bb63f002788b64ed86559addd SHA512 d0029746ea10625bb47381a7ed74aadb8aa3823f83f751b539eefd49da5aa1643a2d16c55fe23d30bd71528ad5c1ea8d389909fe8cc1026746b3b76aa5dabd2b
DIST wf-shell-0.7.0.tar.xz 9014840 BLAKE2B f2e1ffb76de79db580227ddefc10c9f3431c92f77e6519da1102e7c4456bb30c4f25c82570a5b2796985dac00be65f9428ac6682e80920ed22359f63e3e6a84d SHA512 3d72c5d399280ee9da841a417faf696f8baa40edc1040bc1f354f113a8e431dbab428c93928b1d3faa520e35211345cabb5c70f55e10cfb7a4c321a6db19df90
diff --git a/gui-apps/wf-shell/wf-shell-0.5.0.ebuild b/gui-apps/wf-shell/wf-shell-0.5.0.ebuild
deleted file mode 100644
index f4c6ec5dafef..000000000000
--- a/gui-apps/wf-shell/wf-shell-0.5.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="A compiz like 3D wayland compositor"
-HOMEPAGE="https://github.com/WayfireWM/wf-shell"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
-else
- SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/${PV}/${P}.tar.xz"
- KEYWORDS="amd64 ~arm64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="+pulseaudio"
-
-DEPEND="
- dev-cpp/gtkmm:3.0=[wayland]
- dev-libs/gobject-introspection
- >=gui-libs/gtk-layer-shell-0.1
- >=gui-wm/wayfire-${PV}
- pulseaudio? ( media-sound/pulseaudio )
-"
-
-RDEPEND="${DEPEND}"
-
-BDEPEND="
- dev-libs/wayland-protocols
- virtual/pkgconfig
-"
-
-src_configure () {
- local emesonargs=(
- "$(meson_feature pulseaudio pulse)"
- )
- meson_src_configure
-}
diff --git a/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.7.0.ebuild b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.7.0.ebuild
index 4f3377ae6391..7fb2990acf81 100644
--- a/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.7.0.ebuild
+++ b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.7.0.ebuild
@@ -21,8 +21,9 @@ SLOT="0"
DEPEND="
dev-cpp/glibmm:2
- >=gui-libs/wlroots-0.11.0
- >=gui-wm/wayfire-${PV%.*}
+ >=gui-libs/wlroots-0.13.0:=
+ <gui-libs/wlroots-0.14.0:=
+ >=gui-wm/wayfire-0.7.0
x11-libs/cairo
"
RDEPEND="${DEPEND}"
diff --git a/gui-libs/wf-config/Manifest b/gui-libs/wf-config/Manifest
index 870e06de384d..15f9e410c096 100644
--- a/gui-libs/wf-config/Manifest
+++ b/gui-libs/wf-config/Manifest
@@ -1,3 +1 @@
-DIST wf-config-0.5.0.tar.xz 64760 BLAKE2B c1939035820794828b356371c51dbd55a73a569e3a9dcf801b4aedf61c3c0131e47040a1b05e2a8cd30ecbb57f160f702b735437dfb49051a8a6a63d95201204 SHA512 b365884195cb7fc64a1ca1d74a2d12b56e1ef0f4dd49d298a9379455f2917f2c644de2b12f5068304ca404b112490e38fbfe3111aac31d301f02f23429df87c7
-DIST wf-config-0.7.0.tar.xz 73332 BLAKE2B 709a9358e564538b9db8536a5e24f2e7843498830e643ed005801624de9f71ad2661824de75f5b57541ece99d525a4689048c990df5ddc3fdcee6fc83c03e490 SHA512 ddad687b180e786060839cafe5623a0897ade061e6ad057dbe579d51595fbf2dc45674df3fb35070520dc51d7e02d4c9158d9cf8d4619ac49334014f6701f06d
DIST wf-config-0.7.1.tar.xz 39120 BLAKE2B b18048334df12b002391fe4a74529cb61df76a0678c9052f8ac91d777e8a48dae46b87680fb44630ebfb9a350dbac36b15bc81850341fa4cd6299c12f6fa057d SHA512 d535a09a3465a54a607df7b8764ee6818ab8b83536d68c85167b282b95a176636e4bf5cda6c0d1638c07721a1f4208203e9d41b83675038fb590a535314df719
diff --git a/gui-libs/wf-config/wf-config-0.5.0.ebuild b/gui-libs/wf-config/wf-config-0.5.0.ebuild
deleted file mode 100644
index f931c5c75f9f..000000000000
--- a/gui-libs/wf-config/wf-config-0.5.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="library for managing wayfire configuration files"
-HOMEPAGE="https://github.com/WayfireWM/wf-config"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/WayfireWM/wf-config.git"
-else
- SRC_URI="https://github.com/WayfireWM/wf-config/releases/download/${PV}/${P}.tar.xz"
- KEYWORDS="amd64 ~arm64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-DEPEND="
- dev-libs/libevdev
- dev-libs/libxml2
- >=gui-libs/wlroots-0.11.0
- media-libs/glm
-"
-
-RDEPEND="${DEPEND}"
-
-BDEPEND="
- dev-libs/wayland-protocols
- virtual/pkgconfig
-"
diff --git a/gui-libs/wf-config/wf-config-0.7.0.ebuild b/gui-libs/wf-config/wf-config-0.7.0.ebuild
deleted file mode 100644
index 26f5dea6385b..000000000000
--- a/gui-libs/wf-config/wf-config-0.7.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="library for managing wayfire configuration files"
-HOMEPAGE="https://github.com/WayfireWM/wf-config"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/WayfireWM/wf-config.git"
-else
- SRC_URI="https://github.com/WayfireWM/wf-config/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-DEPEND="
- dev-libs/libevdev
- dev-libs/libxml2
- >=gui-libs/wlroots-0.12.0
- media-libs/glm
-"
-
-RDEPEND="${DEPEND}"
-
-BDEPEND="
- dev-libs/wayland-protocols
- virtual/pkgconfig
-"
diff --git a/gui-wm/wayfire/Manifest b/gui-wm/wayfire/Manifest
index f93a447f4284..5454f153084a 100644
--- a/gui-wm/wayfire/Manifest
+++ b/gui-wm/wayfire/Manifest
@@ -1,3 +1 @@
-DIST wayfire-0.5.0.tar.xz 670680 BLAKE2B 6a1555669352dd1303f7472db4fbb8ada6173c09825f4e999a2862787bd5bf31e070e9e12110249b9407d8c380235f4a9d3c5be6b23defe36094822526eed6ef SHA512 9c2d116a5d6e77e37b0e4eef26624d43d6ab3a80e56e19a2de1fdd28a2a522c24b9e346eb4529848f3b2c3668460a51f428a0c196286ec8300e4823250eae811
-DIST wayfire-0.7.0.tar.xz 735756 BLAKE2B 8298cc92938f5196e3dc5bac39d4d9db370e69209461feb5d7abe685e0277efd4bd42ef2c18dc41d79e20d794dae5889efec56f8278fde6efc37b8017c5e65ea SHA512 eaaa193619a6cb0c7a0879aa24a7f6d468e81aeef0b9f17a282f5f930c00557a021f4d45de4aae6f57ce5e427148387c3fdf344ea9c6843a75e777eeeeb96f79
DIST wayfire-0.7.1.tar.xz 753104 BLAKE2B e26b5e770fff44ef04a9d832ed404f05d37448c8ecc0be1e976b8bd0866c2716150bc43394fc4d2fbba1854696eaf54f16dabc632b686f236e66313d0d1eaf59 SHA512 c045ed16d2eb24b508f84d6616021638ec139b99618f5cb834f2b3675d1e549a6cc1bc3150dd97965a16a2a23fe54abe34e4671ce345350a7fb4084f13d7e969
diff --git a/gui-wm/wayfire/wayfire-0.5.0.ebuild b/gui-wm/wayfire/wayfire-0.5.0.ebuild
deleted file mode 100644
index 5b1a4cb2d819..000000000000
--- a/gui-wm/wayfire/wayfire-0.5.0.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="compiz like 3D wayland compositor"
-HOMEPAGE="https://github.com/WayfireWM/wayfire"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
-else
- SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/${PV}/${P}.tar.xz"
- KEYWORDS="amd64 ~arm64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="+gles +system-wfconfig +system-wlroots elogind systemd X"
-REQUIRED_USE="?? ( elogind systemd )"
-
-DEPEND="
- dev-libs/libevdev
- dev-libs/libinput
- gui-libs/gtk-layer-shell
- media-libs/glm
- media-libs/mesa:=[gles2,wayland,X?]
- media-libs/libjpeg-turbo
- media-libs/libpng
- media-libs/freetype:=[X?]
- x11-libs/libdrm
- x11-libs/gtk+:3=[wayland,X?]
- x11-libs/cairo:=[X?,svg]
- X? ( x11-libs/libxkbcommon:=[X] )
- x11-libs/pixman
- gles? ( media-libs/libglvnd[X?] )
- system-wfconfig? ( >=gui-libs/wf-config-${PV} )
- !system-wfconfig? ( !gui-libs/wf-config )
- system-wlroots? ( >=gui-libs/wlroots-0.11.0[elogind=,systemd=,X?] )
- !system-wlroots? ( !gui-libs/wlroots )
-"
-
-RDEPEND="
- ${DEPEND}
- elogind? ( sys-auth/elogind )
- systemd? ( sys-apps/systemd )
- x11-misc/xkeyboard-config
-"
-
-BDEPEND="
- dev-libs/wayland-protocols
- virtual/pkgconfig
-"
-
-src_configure() {
- local emesonargs=(
- $(meson_feature system-wfconfig use_system_wfconfig)
- $(meson_feature system-wlroots use_system_wlroots)
- $(meson_feature X xwayland)
- $(meson_use gles enable_gles32)
- )
- meson_src_configure
-}
-
-src_install() {
- default
- meson_src_install
- einstalldocs
-
- insinto "/usr/share/wayland-sessions/"
- insopts -m644
- doins wayfire.desktop
-
- dodoc wayfire.ini
-
- if ! use systemd && ! use elogind; then
- fowners root:0 /usr/bin/wayfire
- fperms 4511 /usr/bin/wayfire
- fi
-}
-
-pkg_postinst() {
- if [ -z "${REPLACING_VERSIONS}" ]; then
- elog "Wayfire has been installed but the session cannot be used"
- elog "until you install a configuration file. The default config"
- elog "file is installed at \"/usr/share/doc/${PF}/wayfire.ini.bz2\""
- elog "To install the file execute"
- elog "\$ mkdir -p ~/.config && bzcat /usr/share/doc/${PF}/wayfire.ini.bz2 > ~/.config/wayfire.ini"
- fi
-}
diff --git a/gui-wm/wayfire/wayfire-0.7.0.ebuild b/gui-wm/wayfire/wayfire-0.7.0.ebuild
deleted file mode 100644
index 339de620d255..000000000000
--- a/gui-wm/wayfire/wayfire-0.7.0.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="compiz like 3D wayland compositor"
-HOMEPAGE="https://github.com/WayfireWM/wayfire"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
-else
- SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="+gles +system-wfconfig +system-wlroots elogind systemd X"
-REQUIRED_USE="?? ( elogind systemd )"
-
-DEPEND="
- dev-libs/libevdev
- dev-libs/libinput
- gui-libs/gtk-layer-shell
- media-libs/glm
- media-libs/mesa:=[gles2,wayland,X?]
- media-libs/libjpeg-turbo
- media-libs/libpng
- media-libs/freetype:=[X?]
- x11-libs/libdrm
- x11-libs/gtk+:3=[wayland,X?]
- x11-libs/cairo:=[X?,svg]
- X? ( x11-libs/libxkbcommon:=[X] )
- x11-libs/pixman
- gles? ( media-libs/libglvnd[X?] )
- system-wfconfig? ( >=gui-libs/wf-config-${PV%.*} )
- !system-wfconfig? ( !gui-libs/wf-config )
- system-wlroots? ( >=gui-libs/wlroots-0.12.0[elogind=,systemd=,X?] )
- !system-wlroots? ( !gui-libs/wlroots )
-"
-
-RDEPEND="
- ${DEPEND}
- elogind? ( sys-auth/elogind )
- systemd? ( sys-apps/systemd )
- x11-misc/xkeyboard-config
-"
-
-BDEPEND="
- dev-libs/wayland-protocols
- virtual/pkgconfig
-"
-
-src_configure() {
- sed -e "s:@EPREFIX@:${EPREFIX}:" \
- "${FILESDIR}"/wayfire-session > "${T}"/wayfire-session || die
- sed -e "s:@EPREFIX@:${EPREFIX}:" \
- "${FILESDIR}"/wayfire-session.desktop > "${T}"/wayfire-session.desktop || die
- local emesonargs=(
- $(meson_feature system-wfconfig use_system_wfconfig)
- $(meson_feature system-wlroots use_system_wlroots)
- $(meson_feature X xwayland)
- $(meson_use gles enable_gles32)
- )
- meson_src_configure
-}
-
-src_install() {
- default
- meson_src_install
- dobin "${T}"/wayfire-session
- einstalldocs
-
- insinto "/usr/share/wayland-sessions/"
- insopts -m644
- doins wayfire.desktop
- doins "${T}"/wayfire-session.desktop
-
- dodoc wayfire.ini
-
- if ! use systemd && ! use elogind; then
- fowners root:0 /usr/bin/wayfire
- fperms 4511 /usr/bin/wayfire
- fi
-}
-
-pkg_postinst() {
- if [ -z "${REPLACING_VERSIONS}" ]; then
- elog "Wayfire has been installed but the session cannot be used"
- elog "until you install a configuration file. The default config"
- elog "file is installed at \"/usr/share/doc/${PF}/wayfire.ini.bz2\""
- elog "To install the file execute"
- elog "\$ mkdir -p ~/.config && bzcat /usr/share/doc/${PF}/wayfire.ini.bz2 > ~/.config/wayfire.ini"
- fi
-}