summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mate-base/mate-menus/Manifest3
-rw-r--r--mate-base/mate-menus/mate-menus-1.12.0-r1.ebuild72
-rw-r--r--mate-base/mate-menus/mate-menus-1.14.0.ebuild74
-rw-r--r--mate-base/mate-menus/mate-menus-1.16.0.ebuild74
4 files changed, 0 insertions, 223 deletions
diff --git a/mate-base/mate-menus/Manifest b/mate-base/mate-menus/Manifest
index b13c83f48784..d8ac70d1ae36 100644
--- a/mate-base/mate-menus/Manifest
+++ b/mate-base/mate-menus/Manifest
@@ -1,4 +1 @@
-DIST mate-menus-1.12.0.tar.xz 342488 BLAKE2B da9ae8e64d4f498ac360e41646e49ccd0c2d76dddfa417a3bcd07f860e16f66b58679b3aae761fd11d2c9cc1d47a97a444b2de8b2d9d584fc43c1184da38727d SHA512 12788d5b88c1dba7b561a3119e311a9724629d1f9ae7d54a9e4443946b331c532310c79b7b39bcacc791697ac52d4b55338051da66c4d747c371575a03183ba6
-DIST mate-menus-1.14.0.tar.xz 362136 BLAKE2B cb4123add4f5c9e794050e8ee63ce4d8d3f3cf39e68111a8909df5b24ed5c89a1c614c0939616bc2ba0ef73e412d933f694f8e378c09a6fdee959aa04174c79a SHA512 9d82737669b37e85ab76e94e84a464d7cafb837b71d6af90cf08b4286480de901e1a37d279ba7f0af25e655c3c9c67481b1394587b6aad902a284a8ac58559c6
-DIST mate-menus-1.16.0.tar.xz 356832 BLAKE2B 1ef09eedb48424dcd740c37bb83bd7c2e15895506f26faa688f9eb0c4fdeb7c814b039d14e6a26a7ab8ac442e72e8b67a71a09180573ec1b6542b3e49e91be5e SHA512 c6cc3ce73dfdcbe7db4a10c68d1acc5c8433f077576d047b2c3488716ff40733ae86b50480abd5c4fa033275d6f6a04dbe4c6e049a4be85fd132e8291b0d97b5
DIST mate-menus-1.18.1.tar.xz 359768 BLAKE2B c57095e772610c56a02a5b6b1405c5ccc11cb590ea959efa14bd0ffb5cafbe3a678f8a681e39ae9cf607225f57becfc520ec483e6451f07b7f9e80418496502b SHA512 bfd010735acd3447700a4732da16728d429ca8ba559c6bfc6edfdaea52f4e40552882bb09615fc4f040730bffac7614bb74fe18aee3ab8ee1684dad40a82d572
diff --git a/mate-base/mate-menus/mate-menus-1.12.0-r1.ebuild b/mate-base/mate-menus/mate-menus-1.12.0-r1.ebuild
deleted file mode 100644
index 76d6841fb771..000000000000
--- a/mate-base/mate-menus/mate-menus-1.12.0-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-r1 mate
-
-if [[ ${PV} != 9999 ]]; then
- KEYWORDS="amd64 ~arm x86"
-fi
-
-DESCRIPTION="MATE menu system, implementing the F.D.O cross-desktop spec"
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-
-IUSE="debug +introspection python"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND=">=dev-libs/glib-2.36.0:2
- virtual/libintl:0
- introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
- python? (
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- ${PYTHON_DEPS}
- )"
-
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.40:*
- sys-devel/gettext:*
- virtual/pkgconfig:*"
-
-src_prepare() {
- mate_src_prepare
- use python && python_copy_sources
-}
-
-src_configure() {
- # Do NOT compile with --disable-debug/--enable-debug=no as it disables API
- # usage checks.
- mate_py_cond_func_wrap mate_src_configure \
- --enable-debug=$(usex debug yes minimum) \
- $(use_enable python) \
- $(use_enable introspection)
-}
-
-src_compile() {
- mate_py_cond_func_wrap default
-}
-
-src_test() {
- mate_py_cond_func_wrap emake check
-}
-
-src_install() {
- mate_py_cond_func_wrap mate_src_install
-
- exeinto /etc/X11/xinit/xinitrc.d/
- doexe "${FILESDIR}/10-xdg-menu-mate"
-}
-
-pkg_postinst() {
- mate_pkg_postinst
- einfo "Due to upstream bug"
- einfo "https://github.com/mate-desktop/mate-menus/issues/2,"
- einfo "it is highly recommended to run the following command"
- einfo "once you have logged in to your desktop for the first time:"
- einfo "cd ~/.config/menus && ln -s {,mate-}applications-merged"
-}
diff --git a/mate-base/mate-menus/mate-menus-1.14.0.ebuild b/mate-base/mate-menus/mate-menus-1.14.0.ebuild
deleted file mode 100644
index f32609d8757d..000000000000
--- a/mate-base/mate-menus/mate-menus-1.14.0.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-r1 mate
-
-if [[ ${PV} != 9999 ]]; then
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-DESCRIPTION="MATE menu system, implementing the F.D.O cross-desktop spec"
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-
-IUSE="debug +introspection python"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-COMMON_DEPEND=">=dev-libs/glib-2.36.0:2
- virtual/libintl:0
- introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
- python? (
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- ${PYTHON_DEPS}
- )"
-
-RDEPEND="${COMMON_DEPEND}"
-
-DEPEND="${COMMON_DEPEND}
- >=dev-util/intltool-0.40:*
- sys-devel/gettext:*
- virtual/pkgconfig:*"
-
-src_prepare() {
- mate_src_prepare
- use python && python_copy_sources
-}
-
-src_configure() {
- # Do NOT compile with --disable-debug/--enable-debug=no as it disables API
- # usage checks.
- mate_py_cond_func_wrap mate_src_configure \
- --enable-debug=$(usex debug yes minimum) \
- $(use_enable python) \
- $(use_enable introspection)
-}
-
-src_compile() {
- mate_py_cond_func_wrap default
-}
-
-src_test() {
- mate_py_cond_func_wrap emake check
-}
-
-src_install() {
- mate_py_cond_func_wrap mate_src_install
-
- exeinto /etc/X11/xinit/xinitrc.d/
- doexe "${FILESDIR}/10-xdg-menu-mate"
-}
-
-pkg_postinst() {
- mate_pkg_postinst
- einfo "Due to upstream bug"
- einfo "https://github.com/mate-desktop/mate-menus/issues/2,"
- einfo "it is highly recommended to run the following command"
- einfo "once you have logged in to your desktop for the first time:"
- einfo "cd ~/.config/menus && ln -s {,mate-}applications-merged"
-}
diff --git a/mate-base/mate-menus/mate-menus-1.16.0.ebuild b/mate-base/mate-menus/mate-menus-1.16.0.ebuild
deleted file mode 100644
index f32609d8757d..000000000000
--- a/mate-base/mate-menus/mate-menus-1.16.0.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-r1 mate
-
-if [[ ${PV} != 9999 ]]; then
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-DESCRIPTION="MATE menu system, implementing the F.D.O cross-desktop spec"
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-
-IUSE="debug +introspection python"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-COMMON_DEPEND=">=dev-libs/glib-2.36.0:2
- virtual/libintl:0
- introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
- python? (
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- ${PYTHON_DEPS}
- )"
-
-RDEPEND="${COMMON_DEPEND}"
-
-DEPEND="${COMMON_DEPEND}
- >=dev-util/intltool-0.40:*
- sys-devel/gettext:*
- virtual/pkgconfig:*"
-
-src_prepare() {
- mate_src_prepare
- use python && python_copy_sources
-}
-
-src_configure() {
- # Do NOT compile with --disable-debug/--enable-debug=no as it disables API
- # usage checks.
- mate_py_cond_func_wrap mate_src_configure \
- --enable-debug=$(usex debug yes minimum) \
- $(use_enable python) \
- $(use_enable introspection)
-}
-
-src_compile() {
- mate_py_cond_func_wrap default
-}
-
-src_test() {
- mate_py_cond_func_wrap emake check
-}
-
-src_install() {
- mate_py_cond_func_wrap mate_src_install
-
- exeinto /etc/X11/xinit/xinitrc.d/
- doexe "${FILESDIR}/10-xdg-menu-mate"
-}
-
-pkg_postinst() {
- mate_pkg_postinst
- einfo "Due to upstream bug"
- einfo "https://github.com/mate-desktop/mate-menus/issues/2,"
- einfo "it is highly recommended to run the following command"
- einfo "once you have logged in to your desktop for the first time:"
- einfo "cd ~/.config/menus && ln -s {,mate-}applications-merged"
-}