summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/make/files/make-3.82-darwin-library_search-dylib.patch4
-rw-r--r--sys-devel/make/files/make-4.2.1-glob-v2.patch34
-rw-r--r--sys-devel/make/make-4.2.1-r2.ebuild (renamed from sys-devel/make/make-4.2.1-r1.ebuild)20
3 files changed, 32 insertions, 26 deletions
diff --git a/sys-devel/make/files/make-3.82-darwin-library_search-dylib.patch b/sys-devel/make/files/make-3.82-darwin-library_search-dylib.patch
index de7e4f615212..d2f60ec91cc0 100644
--- a/sys-devel/make/files/make-3.82-darwin-library_search-dylib.patch
+++ b/sys-devel/make/files/make-3.82-darwin-library_search-dylib.patch
@@ -1,8 +1,8 @@
Fixed default libpatttern on Darwin, imported from prefix overlay.
Got merged upstream:
https://savannah.gnu.org/bugs/?37197
---- default.c.orig 2009-05-02 12:25:24 +0200
-+++ default.c 2009-05-02 12:25:58 +0200
+--- a/default.c
++++ b/default.c
@@ -509,7 +509,11 @@
#ifdef __MSDOS__
".LIBPATTERNS", "lib%.a $(DJDIR)/lib/lib%.a",
diff --git a/sys-devel/make/files/make-4.2.1-glob-v2.patch b/sys-devel/make/files/make-4.2.1-glob-v2.patch
index a9aeb787cd72..e55a7790a3f6 100644
--- a/sys-devel/make/files/make-4.2.1-glob-v2.patch
+++ b/sys-devel/make/files/make-4.2.1-glob-v2.patch
@@ -1,17 +1,22 @@
-From 48c8a116a914a325a0497721f5d8b58d5bba34d4 Mon Sep 17 00:00:00 2001
-From: Paul Smith <psmith@gnu.org>
-Date: Sun, 19 Nov 2017 15:09:16 -0500
-Subject: [PATCH] * configure.ac: Support GLIBC glob interface version 2
+http://git.savannah.gnu.org/cgit/make.git/commit/?id=48c8a116a914a325a0497721f5d8b58d5bba34d4
----
- configure.ac | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 8c72568..4710832 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -404,10 +404,9 @@ AC_CACHE_CHECK([if system libc has GNU glob], [make_cv_sys_gnu_glob],
+--- make-4.2.1/configure 2016-06-11 01:03:21.000000000 +0200
++++ make-4.2.1/configure 2016-06-11 01:03:21.000000000 +0200
+@@ -11481,10 +11481,9 @@
+ #include <glob.h>
+ #include <fnmatch.h>
+
+-#define GLOB_INTERFACE_VERSION 1
+ #if !defined _LIBC && defined __GNU_LIBRARY__ && __GNU_LIBRARY__ > 1
+ # include <gnu-versions.h>
+-# if _GNU_GLOB_INTERFACE_VERSION == GLOB_INTERFACE_VERSION
++# if _GNU_GLOB_INTERFACE_VERSION == 1 || _GNU_GLOB_INTERFACE_VERSION == 2
+ gnu glob
+ # endif
+ #endif
+--- make-4.2.1/configure.ac 2016-06-06 14:27:31.000000000 +0200
++++ make-4.2.1/configure.ac 2016-06-06 14:27:31.000000000 +0200
+@@ -399,10 +399,9 @@
#include <glob.h>
#include <fnmatch.h>
@@ -23,6 +28,3 @@ index 8c72568..4710832 100644
gnu glob
# endif
#endif],
---
-2.16.1
-
diff --git a/sys-devel/make/make-4.2.1-r1.ebuild b/sys-devel/make/make-4.2.1-r2.ebuild
index d0f079cef26d..16e61927b881 100644
--- a/sys-devel/make/make-4.2.1-r1.ebuild
+++ b/sys-devel/make/make-4.2.1-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit flag-o-matic eutils
+inherit flag-o-matic
DESCRIPTION="Standard tool to compile source trees"
HOMEPAGE="https://www.gnu.org/software/make/make.html"
@@ -25,20 +25,24 @@ PATCHES=(
"${FILESDIR}"/${PN}-4.2-default-cxx.patch
"${FILESDIR}"/${PN}-4.2.1-perl526.patch
"${FILESDIR}"/${PN}-4.2.1-glob-internals.patch
- "${FILESDIR}"/${PN}-4.2.1-glob-v2.patch
)
src_prepare() {
- epatch "${PATCHES[@]}"
- epatch_user
+ default
+ # This patch requires special handling as it modifies confiure.ac
+ # which in turn triggers maintainer-mode when being applied the
+ # usual way.
+ eapply -Z "${FILESDIR}"/${PN}-4.2.1-glob-v2.patch
}
src_configure() {
use static && append-ldflags -static
- econf \
- --program-prefix=g \
- $(use_with guile) \
+ local myeconfargs=(
+ --program-prefix=g
+ $(use_with guile)
$(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {