summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-1.5.5.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index fd7c97fd8c5f..e27b1a9fbe7d 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -4,3 +4,4 @@ DIST pylint-1.5.1.tar.gz 419684 SHA256 044e9f03eee51ac1cb05f094af6ccc2a2195c558d
DIST pylint-1.5.2.tar.gz 419023 SHA256 983bec35e10b0c5f0ec33c03629fe832642c46b76a43edce37a2e8d2708d2179 SHA512 27c4c28ff2aa80fba95033c84af7732365dcf8351cd0caee0205d28100106e194071d51d17d133ccf5ea95a6165896c43851dd397e02676d12720f426cc52afc WHIRLPOOL 16eebbd15f1af4b1932e26419ecb607604fc4b25973c54c444f98be46fd95b374bb0ddc8e5bd3880a272766426f241d6a694433ec9db8d44b559ecda7d231321
DIST pylint-1.5.3.tar.gz 422412 SHA256 c0a5d4123873455292d1e360cceb1ee8527edb74783ddb4882cf22a2de86be76 SHA512 1321211b04a85fe6961858e6b6e2c40429a4a5713784f4bc7507f87063e0877d0299789650915f2c81f8c4b6df6ff5bc566e79267afa4b070763c28cb7643891 WHIRLPOOL aaeef16064e742a6f39a77745ec9f2b97038f88f14b4dedff83916bb3d782d01456f659d12d16d8c45f32c6ebf45334d40ad1c18356b7cabfaad165cd83b3447
DIST pylint-1.5.4.tar.gz 423215 SHA256 2fe3cc2fc66a56fdc35dbbc2bf1dd96a534abfc79ee6b2ad9ae4fe166e570c4b SHA512 7317ef694133041aabffec3f31366b32de0adcb90b67dd70a6cc1a5abea022e59377afaf4f7f53f59049673697524ccf8a02419fdadc3bf98ceaec625fc5d08d WHIRLPOOL 5587d3be0a5cde145544faf4a2d62fca7c2e6cc100e5a948b8066a4ff756d7a775a0b1458336c1c6802ce605acca90ea809e96c99d06e9ee6ec6ecbd8f15b25a
+DIST pylint-1.5.5.tar.gz 424040 SHA256 15e949bbeda6c0a66799f34f720ab15e38d0a128e752cff5e74168527e5399c7 SHA512 cb3b532f88d2c75e1cef8fefd6e96e8d12a4d56b4bc7e84e109d5d093c8e2a9465d02cfb650f3dd3916edf753e20541b3ec4162743af9f7c82563ecd4b8cc7c6 WHIRLPOOL 665f8c315d61ba2e08ad4c5dea5e2fd20988fc258a856d5cb64a5da2e52e7f701803cab64672de825dfedf89890c194692491a07155880d309c2d27d121d00d3
diff --git a/dev-python/pylint/pylint-1.5.5.ebuild b/dev-python/pylint/pylint-1.5.5.ebuild
new file mode 100644
index 000000000000..355d5cfb4634
--- /dev/null
+++ b/dev-python/pylint/pylint-1.5.5.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="
+ http://www.logilab.org/project/pylint
+ https://pypi.python.org/pypi/pylint
+ https://github.com/pycqa/pylint"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc examples test"
+
+RDEPEND="
+ >=dev-python/astroid-1.4.1[${PYTHON_USEDEP}]
+ <dev-python/astroid-1.5.0[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND} )"
+
+RESTRICT="test" # multiple failures
+
+# Usual. Requ'd for impl specific failures in test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ # selection of straight html triggers a trivial annoying bug, we skirt it
+ use doc && PYTHONPATH="${S}" emake -e -C doc singlehtml
+}
+
+python_test() {
+ ${PYTHON} \
+ -m unittest discover \
+ -s pylint/test/ -p "*test_*".py \
+ --verbose || die
+}
+
+python_install_all() {
+ doman man/{pylint,pyreverse}.1
+ use examples && local EXAMPLES=( examples/. )
+ use doc && local HTML_DOCS=( doc/_build/singlehtml/. )
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ # Optional dependency on "tk" USE flag would break support for Jython.
+ optfeature "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled." dev-lang/python[tk]
+}