summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/airdcpp-webclient/Manifest1
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-1.0.0.ebuild62
-rw-r--r--net-p2p/airdcpp-webclient/files/airdcppd.confd8
-rw-r--r--net-p2p/airdcpp-webclient/files/airdcppd.initd21
-rw-r--r--net-p2p/airdcpp-webclient/metadata.xml2
5 files changed, 94 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index cbd055e98044..6733eb915fcf 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1 +1,2 @@
DIST airdcpp-webclient-0.16.5.tar.gz 702187 SHA256 d153621ce390ee5d434a63d8af5d46b4b54638984de35ee8340ca63f27f61e16 SHA512 decc359aa569de8d3ae117a7f9ce38d9234564401072a776271ce7dff1e24022ad8d01fbf9cf4cc5238778c3c0cb7031b33e2e8d6a1014034ef507a8c29a6f7b WHIRLPOOL 3c71a391dd3e7a5defa5ec8a3abf580b5850abade28b763ad2548f0cc6df5345002c3a07e7e9db33abdedbd60740b62fc27fb0f8af5022353ac35cb826437e18
+DIST airdcpp-webclient-1.0.0.tar.gz 705277 SHA256 46c19884e220f39924a59c98d09743f2e9017a11bc81f7f95f5419798627813b SHA512 5a8523f15f6ee598d9b5dde502a80831ab8bb7c36c2fa60abb88232619c1e0f64ee3a2d08f1f90ec1a8af6ee0571733f353514522975614fc036d9f6655610ac WHIRLPOOL ef9aad1bc02fdcf66355ceea9302bacb79a69561b507963cec59bfb9f423d17316edcbccb1edba596e0acd93971eaf6f45661f5f90b3d16b007ed42b39e67535
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-1.0.0.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-1.0.0.ebuild
new file mode 100644
index 000000000000..9c383243f1bd
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-1.0.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils user
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://github.com/airdcpp-web/airdcpp-webclient"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nat-pmp +tbb +webui"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost
+ dev-libs/geoip
+ dev-libs/leveldb
+ dev-libs/openssl:0=
+ net-libs/miniupnpc
+ sys-libs/zlib
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp )
+ tbb? ( dev-cpp/tbb )
+"
+DEPEND="
+ dev-lang/python:*
+ ${RDEPEND}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_WEB_UI=OFF
+ -DLIB_INSTALL_DIR=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ keepdir /var/lib/airdcppd
+ fowners airdcppd:airdcppd /var/lib/airdcppd
+ cmake-utils_src_install
+}
+
+pkg_setup() {
+ enewgroup airdcppd
+ enewuser airdcppd -1 -1 /var/lib/airdcppd airdcppd
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}
diff --git a/net-p2p/airdcpp-webclient/files/airdcppd.confd b/net-p2p/airdcpp-webclient/files/airdcppd.confd
new file mode 100644
index 000000000000..af140cb6d3bf
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/files/airdcppd.confd
@@ -0,0 +1,8 @@
+# /etc/conf.d/airdcppd: config file for /etc/init.d/airdcppd
+
+# User and group as which to run
+#AIRDCPPD_USER="airdcppd"
+#AIRDCPPD_GROUP="airdcppd"
+
+# umask used to create files
+#AIRDCPPD_UMASK=007
diff --git a/net-p2p/airdcpp-webclient/files/airdcppd.initd b/net-p2p/airdcpp-webclient/files/airdcppd.initd
new file mode 100644
index 000000000000..53e6145b0690
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/files/airdcppd.initd
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+AIRDCPPD_USER="${AIRDCPPD_USER:-${RC_SVCNAME}}"
+AIRDCPPD_GROUP="${AIRDCPPD_GROUP:-${RC_SVCNAME}}"
+AIRDCPPD_UMASK="${SYNCTHING_UMASK:-007}"
+AIRDCPPD_HOME="$(getent passwd "${AIRDCPPD_USER}" | cut -d: -f6)"
+
+command="/usr/bin/airdcppd"
+pidfile="${AIRDCPPD_HOME}/.airdc++/${RC_SVCNAME}.pid"
+command_args="-d"
+start_stop_daemon_args="\
+ --user ${AIRDCPPD_USER} \
+ --group ${AIRDCPPD_GROUP} \
+ --umask ${AIRDCPPD_UMASK} \
+"
+
+depend() {
+ need localmount net
+}
diff --git a/net-p2p/airdcpp-webclient/metadata.xml b/net-p2p/airdcpp-webclient/metadata.xml
index 36c434f643b7..c8f06e0b207a 100644
--- a/net-p2p/airdcpp-webclient/metadata.xml
+++ b/net-p2p/airdcpp-webclient/metadata.xml
@@ -18,6 +18,8 @@
AirDC++ Web Client is a cross-platform peer-to-peer file sharing client which allows sharing files with groups of people.
</longdescription>
<use>
+ <flag name="nat-pmp">Enable support for the NAT-PMP protocol</flag>
+ <flag name="tbb">Enable support of the TBB library to improve performance</flag>
<flag name="webui">Enable the Web UI</flag>
</use>
</pkgmetadata>