summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.22.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index 874e2e9d4b67..2f89ec54b689 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,2 +1,3 @@
DIST plasma-integration-5.21.5.tar.xz 60972 BLAKE2B 2122d64fa98dcd65936b18a5f8c09939680566770468817ab14d9116c92d226f234811952fd61222ca5e000fe213735c0da26ce73f3c5587cff4d61fcf88d902 SHA512 655fee4335569325431e9fb7d368bdf82b43f1e0e0f727f95f11f481a81e8dbdcdc43470c1768b9ab5701159ffaf571b551edc57510a653e1c7fedc1c4216d92
DIST plasma-integration-5.22.0.tar.xz 65148 BLAKE2B e67304ac62c744bee30e7e1ef38bb65d652aa05719169ff0c034e3af1d8b3ab9f4580d5f78a2ee6bf958f0267b8cae916c094e840ae3b0915a3a8391636af034 SHA512 0383d3c014c294c31e2dac3ef299288a6c67aeaec3e3367784add413c38edb16c96552fe315a4b77ded516c9e8efe246ae49dd98ab42efa13476dcafffe91315
+DIST plasma-integration-5.22.1.tar.xz 65132 BLAKE2B 474cba63d42597f9bed26bd962ea7c8dffeaa19262bb1846282458bff19ca7ec5a71aa4e3130588d1525e550a5569b549d7f200b24690976d033df0fb9048f75 SHA512 840bce02c7d03d490905aef7831ff46d967c0a7e08c2377cc5c0556e955cb12de55aa2f4095925bd3b5ba64658d933022e49801e4a27b8458158a88d0c2edbe3
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.22.1.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.22.1.ebuild
new file mode 100644
index 000000000000..02ab146b45d2
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.22.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.82.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+# requires running kde environment
+RESTRICT+=" test"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5=[dbus]
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-plasma/breeze-${PVCUT}:5
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"