summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/x264/x264-0.0.20190903.ebuild6
-rw-r--r--media-libs/x264/x264-9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/media-libs/x264/x264-0.0.20190903.ebuild b/media-libs/x264/x264-0.0.20190903.ebuild
index bb3c2d15e52e..505ad4d2ed4f 100644
--- a/media-libs/x264/x264-0.0.20190903.ebuild
+++ b/media-libs/x264/x264-0.0.20190903.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,7 +20,7 @@ fi
SLOT="0/157" # SONAME
LICENSE="GPL-2"
-IUSE="altivec +interlaced opencl pic static-libs cpu_flags_x86_sse +threads"
+IUSE="cpu_flags_ppc_altivec +interlaced opencl pic static-libs cpu_flags_x86_sse +threads"
ASM_DEP=">=dev-lang/nasm-2.13"
DEPEND="abi_x86_32? ( ${ASM_DEP} )
@@ -34,7 +34,7 @@ multilib_src_configure() {
tc-export CC
local asm_conf=""
- if [[ ${ABI} == x86* ]] && { use pic || use !cpu_flags_x86_sse ; } || [[ ${ABI} == "x32" ]] || [[ ${CHOST} == armv5* ]] || [[ ${ABI} == ppc* ]] && { use !altivec ; }; then
+ if [[ ${ABI} == x86* ]] && { use pic || use !cpu_flags_x86_sse ; } || [[ ${ABI} == "x32" ]] || [[ ${CHOST} == armv5* ]] || [[ ${ABI} == ppc* ]] && { use !cpu_flags_ppc_altivec ; }; then
asm_conf=" --disable-asm"
fi
diff --git a/media-libs/x264/x264-9999.ebuild b/media-libs/x264/x264-9999.ebuild
index 5478a141f758..2ddcd7e513cd 100644
--- a/media-libs/x264/x264-9999.ebuild
+++ b/media-libs/x264/x264-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,7 +20,7 @@ fi
SLOT="0/159" # SONAME
LICENSE="GPL-2"
-IUSE="altivec +interlaced opencl pic static-libs cpu_flags_x86_sse +threads"
+IUSE="cpu_flags_ppc_altivec +interlaced opencl pic static-libs cpu_flags_x86_sse +threads"
ASM_DEP=">=dev-lang/nasm-2.13"
DEPEND="abi_x86_32? ( ${ASM_DEP} )
@@ -34,7 +34,7 @@ multilib_src_configure() {
tc-export CC
local asm_conf=""
- if [[ ${ABI} == x86* ]] && { use pic || use !cpu_flags_x86_sse ; } || [[ ${ABI} == "x32" ]] || [[ ${CHOST} == armv5* ]] || [[ ${ABI} == ppc* ]] && { use !altivec ; }; then
+ if [[ ${ABI} == x86* ]] && { use pic || use !cpu_flags_x86_sse ; } || [[ ${ABI} == "x32" ]] || [[ ${CHOST} == armv5* ]] || [[ ${ABI} == ppc* ]] && { use !cpu_flags_ppc_altivec ; }; then
asm_conf=" --disable-asm"
fi