summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/qjackctl/Manifest1
-rw-r--r--media-sound/qjackctl/qjackctl-0.6.3.ebuild53
-rw-r--r--media-sound/qjackctl/qjackctl-9999.ebuild10
3 files changed, 55 insertions, 9 deletions
diff --git a/media-sound/qjackctl/Manifest b/media-sound/qjackctl/Manifest
index 4d1b9e541fae..8474bdeee863 100644
--- a/media-sound/qjackctl/Manifest
+++ b/media-sound/qjackctl/Manifest
@@ -1 +1,2 @@
DIST qjackctl-0.6.2.tar.gz 1027742 BLAKE2B d2db9e0496223844e3cb289aa8c4ae136011ad36578f3526fd54b44344606e14885d7272bd8e333035b2c908216e60ce2bfe7698c4c8395fd3b017da6b64f03f SHA512 a05f514d749b4f2344c7f0d57a2a0dd1ac6a97f35d0227827e78d3bd7abfbddc3201e2fc7e23f878cd318e408f169a4006a150dc0e43101086e9ba32004e5520
+DIST qjackctl-0.6.3.tar.gz 1033664 BLAKE2B 98d80d0fea3db359b732fad14711352ba688e605b7225daad64d7df1dabf1d19e24b4d643581f1936afa0df0c84350cf5727686246bd8a850e09da969a228e44 SHA512 72a9218b3b8a6b72470656e774f5cfbfe6670059e9f1a85a394345f4689c5d5c05af23b5e37d5f8dfc6159e591f64249006936069dde1632ef9d74b6f8355e0b
diff --git a/media-sound/qjackctl/qjackctl-0.6.3.ebuild b/media-sound/qjackctl/qjackctl-0.6.3.ebuild
new file mode 100644
index 000000000000..00a83f8b64bf
--- /dev/null
+++ b/media-sound/qjackctl/qjackctl-0.6.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic qmake-utils xdg
+
+DESCRIPTION="Qt GUI to control the JACK Audio Connection Kit and ALSA sequencer connections"
+HOMEPAGE="https://qjackctl.sourceforge.io/"
+SRC_URI="mirror://sourceforge/qjackctl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa dbus debug portaudio"
+
+BDEPEND="dev-qt/linguist-tools:5"
+RDEPEND="
+ app-arch/gzip
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ virtual/jack
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( dev-qt/qtdbus:5 )
+ portaudio? ( media-libs/portaudio )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ append-cxxflags -std=c++11
+ local myeconfargs=(
+ $(use_enable alsa alsa-seq)
+ $(use_enable dbus)
+ $(use_enable debug)
+ $(use_enable portaudio)
+ --enable-jack-version
+ )
+ econf "${myeconfargs[@]}"
+ eqmake5 ${PN}.pro -o ${PN}.mak
+}
+
+src_compile() {
+ emake -f ${PN}.mak
+}
+
+src_install() {
+ default
+
+ gunzip "${D}/usr/share/man/man1/qjackctl.fr.1.gz" || die
+ gunzip "${D}/usr/share/man/man1/qjackctl.1.gz" || die
+}
diff --git a/media-sound/qjackctl/qjackctl-9999.ebuild b/media-sound/qjackctl/qjackctl-9999.ebuild
index 3d91bddef6f4..61dd95c2c302 100644
--- a/media-sound/qjackctl/qjackctl-9999.ebuild
+++ b/media-sound/qjackctl/qjackctl-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic qmake-utils autotools git-r3 xdg-utils
+inherit flag-o-matic qmake-utils autotools git-r3 xdg
DESCRIPTION="Qt GUI to control the JACK Audio Connection Kit and ALSA sequencer connections"
HOMEPAGE="https://qjackctl.sourceforge.io/"
@@ -56,11 +56,3 @@ src_install() {
gunzip "${D}/usr/share/man/man1/qjackctl.fr.1.gz" || die
gunzip "${D}/usr/share/man/man1/qjackctl.1.gz" || die
}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}