summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/ppx_deriving/Manifest1
-rw-r--r--dev-ml/ppx_deriving/ppx_deriving-4.2-r1.ebuild52
2 files changed, 0 insertions, 53 deletions
diff --git a/dev-ml/ppx_deriving/Manifest b/dev-ml/ppx_deriving/Manifest
index 23ba45711d2c..78e8351a334a 100644
--- a/dev-ml/ppx_deriving/Manifest
+++ b/dev-ml/ppx_deriving/Manifest
@@ -1,2 +1 @@
-DIST ppx_deriving-4.2.tar.gz 48327 BLAKE2B 8ce5ccbfb7992fbd5e9c777ad0b577f8846d92df21926a877fb8f7b6804acc4fa2fd78586fc209c3bd83b8496eb6f8e8ee37c39e0c7462fb55f39389356f3c8f SHA512 084526157d6f4b41f7ad73157c5edb54d5bb9130d706525031670d8495ede8af5545302f442c2d2c506772201b79ccc93bdc7fead9455d3a59977ddfa9c3284d
DIST ppx_deriving-4.5.tar.gz 45886 BLAKE2B 257bacda986a3830e3efd55b8e97d8c633b64740a36c7954c7b13ef42578fef8795f268e709a2b7285fa3dda1297afe7cfcc277da8557ed654dda6401a550680 SHA512 f79153c5231ba1e03a3491fde95ca82ecb62fe05b60a649a374d2fbc5ea5dd9242126de7dfbe917c22fd7077c026c940e18c6b36c5ce0ec4bb6e07f11d2b710b
diff --git a/dev-ml/ppx_deriving/ppx_deriving-4.2-r1.ebuild b/dev-ml/ppx_deriving/ppx_deriving-4.2-r1.ebuild
deleted file mode 100644
index 5b315e69bee2..000000000000
--- a/dev-ml/ppx_deriving/ppx_deriving-4.2-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit findlib eutils opam
-
-DESCRIPTION="Type-driven code generation for OCaml"
-HOMEPAGE="https://github.com/ocaml-ppx/ppx_deriving"
-SRC_URI="https://github.com/ocaml-ppx/ppx_deriving/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc +ocamlopt test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-ml/ppx_tools:=
- dev-ml/ocaml-migrate-parsetree:=
- dev-ml/ppx_derivers:=
- dev-ml/result:=
-"
-RDEPEND="${DEPEND}"
-DEPEND="${RDEPEND}
- dev-ml/cppo
- test? ( dev-ml/ounit )"
-
-src_compile() {
- cp pkg/META.in pkg/META || die
- ocaml pkg/build.ml \
- native=$(usex ocamlopt true false) \
- native-dynlink=$(usex ocamlopt true false) \
- || die
- use doc && emake doc
-}
-
-src_test() {
- ocamlbuild -j 0 -use-ocamlfind -classic-display \
- src_test/test_ppx_deriving.byte -- || die
- if use ocamlopt; then
- ocamlbuild -j 0 -use-ocamlfind -classic-display \
- src_test/test_ppx_deriving.native -- || die
- fi
-}
-
-src_install() {
- opam_src_install
- mv "${ED}/usr/lib/ppx_deriving/ppx_deriving" "${D}/$(ocamlc -where)/ppx_deriving/" || die
-
- use doc && dohtml api.docdir/*
-}