summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-plugins/gst-plugins-smoothstreaming/Manifest1
-rw-r--r--media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.14.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-smoothstreaming/Manifest b/media-plugins/gst-plugins-smoothstreaming/Manifest
index 9365af3a0a57..52d80951ea53 100644
--- a/media-plugins/gst-plugins-smoothstreaming/Manifest
+++ b/media-plugins/gst-plugins-smoothstreaming/Manifest
@@ -1,2 +1,3 @@
DIST gst-plugins-bad-1.12.3.tar.xz 4707000 BLAKE2B 1cb82e6f1c20d24a42ed0c7465e4dd8815627b0e716fe9be5d005ddd609c92a08619214a6b15059e7f537dadbc36c34d4c6ebfde1284c6a6029d2edf89bf9fa2 SHA512 6df47381de3a2f4286d047c1e7de2c76dd4312c9806636e2012717282cde0f3e5b2d0ffa910c564c8e122b19363e842b663cce1eda7ae95a05d63d1dbbd52661
DIST gst-plugins-bad-1.12.4.tar.xz 4709272 BLAKE2B a4d1fec48fdd67fc66eb5588dbee820c22b19a41dda4f5643b1ae326bfc827cd4796fc7a523fb0a9758605952377a2491f4e53ea74237ca7841659dea4ddcbc0 SHA512 a8e281aee1f1d0bb3f171fbe4242e997c661cbfd0be78da3913c0f55d68d6b7c3d34cabfcdd8c25728217ff885b86a7bedc0be34a7b14e2eb2a6c6236753231b
+DIST gst-plugins-bad-1.14.1.tar.xz 4651852 BLAKE2B 915798f9d07e18b445cae818978def1356299034d14ca2cba8f07df93d5dcf5ed257290bf111298c4f8063b32ceee38dd78c02eae508f6e88956b132740bfa36 SHA512 6969b6c91279fb96bc28acde0284ce980b3982ae0c77820284a903beee61dffa863554dcfadb55de1987404b59c3c7c421372e65dc7b4014fe64a0c91d4ce729
diff --git a/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.14.1.ebuild b/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.14.1.ebuild
new file mode 100644
index 000000000000..2ec5feec35fd
--- /dev/null
+++ b/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.14.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE=gst-plugins-bad
+
+inherit gstreamer
+
+DESCRIPTION="Smooth Streaming plugin for GStreamer"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # FIXME: gsturidownloader does not have a .pc
+ # gst-libs/gst/uridownloader:gsturidownloader \
+ # gst-libs/gst/adaptativedemux:gstadaptivedemux \
+ # gst-libs/gst/isoff:gstisoff
+ gstreamer_system_link \
+ gst-libs/gst/codecparsers:gstreamer-codecparsers
+
+ local directory libs
+ directory="gst-libs/gst/uridownloader"
+ libs="-lgstbase-1.0 -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0 -lgsturidownloader-1.0"
+ sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
+ -i ext/smoothstreaming/Makefile.{am,in} || die
+
+ directory="gst-libs/gst/adaptivedemux"
+ libs="-lgsturidownloader-1.0 -lgstapp-1.0 -lgstbase-1.0 -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0 -lgstadaptivedemux-1.0"
+ sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
+ -i ext/smoothstreaming/Makefile.{am,in} || die
+
+ directory="gst-libs/gst/isoff"
+ libs="-lgstbase-1.0 -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0 -lgstisoff-1.0"
+ sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
+ -i ext/smoothstreaming/Makefile.{am,in} || die
+}