summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/sdl-terminal/sdl-terminal-1.1.3-r1.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/media-libs/sdl-terminal/sdl-terminal-1.1.3-r1.ebuild b/media-libs/sdl-terminal/sdl-terminal-1.1.3-r1.ebuild
index e78133814abf..bbbb2b622b93 100644
--- a/media-libs/sdl-terminal/sdl-terminal-1.1.3-r1.ebuild
+++ b/media-libs/sdl-terminal/sdl-terminal-1.1.3-r1.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
-inherit base libtool autotools
+EAPI=5
+inherit eutils autotools
MY_P="${P/sdl-/SDL_}"
DESCRIPTION="library that provides a pseudo-ansi color terminal that can be used with any SDL application"
@@ -17,13 +17,12 @@ IUSE="static-libs"
DEPEND="virtual/opengl
virtual/glu
- >=media-libs/libsdl-1.2.4
+ >=media-libs/libsdl-1.2.4[opengl]
media-libs/sdl-ttf"
+RDEPEND=${DEPEND}
S=${WORKDIR}/${MY_P}
-DOCS=( AUTHORS ChangeLog README )
-
src_prepare() {
epatch "${FILESDIR}"/${P}-nopython.patch
eautoreconf
@@ -34,6 +33,7 @@ src_configure() {
}
src_install() {
- default
- use static-libs || prune_libtool_files
+ DOCS="AUTHORS ChangeLog README" \
+ default
+ prune_libtool_files
}