summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.10.1.ebuild4
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.9.4-r1.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/dev-libs/libgcrypt/libgcrypt-1.10.1.ebuild b/dev-libs/libgcrypt/libgcrypt-1.10.1.ebuild
index fd9f8ebaf6e8..00b641cf2b84 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.10.1.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.10.1.ebuild
@@ -14,7 +14,7 @@ SRC_URI+=" verify-sig? ( mirror://gnupg/${PN}/${P}.tar.bz2.sig )"
LICENSE="LGPL-2.1 MIT"
SLOT="0/20" # subslot = soname major version
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="+asm cpu_flags_arm_neon cpu_flags_arm_aes cpu_flags_arm_sha1 cpu_flags_arm_sha2 cpu_flags_ppc_altivec cpu_flags_ppc_vsx2 cpu_flags_ppc_vsx3 cpu_flags_x86_aes cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_padlock cpu_flags_x86_sha cpu_flags_x86_sse4_1 doc +o-flag-munging static-libs"
+IUSE="+asm custom-cflags cpu_flags_arm_neon cpu_flags_arm_aes cpu_flags_arm_sha1 cpu_flags_arm_sha2 cpu_flags_ppc_altivec cpu_flags_ppc_vsx2 cpu_flags_ppc_vsx3 cpu_flags_x86_aes cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_padlock cpu_flags_x86_sha cpu_flags_x86_sse4_1 doc static-libs"
# Build system only has --disable-arm-crypto-support right now
# If changing this, update src_configure logic too.
@@ -92,7 +92,7 @@ multilib_src_configure() {
$(use_enable cpu_flags_x86_sse4_1 sse41-support)
# required for sys-power/suspend[crypt], bug 751568
$(use_enable static-libs static)
- $(use_enable o-flag-munging O-flag-munging)
+ $(use_enable !custom-cflags O-flag-munging)
# disabled due to various applications requiring privileges
# after libgcrypt drops them (bug #468616)
diff --git a/dev-libs/libgcrypt/libgcrypt-1.9.4-r1.ebuild b/dev-libs/libgcrypt/libgcrypt-1.9.4-r1.ebuild
index cf2e518df50e..8a228b0fe2c4 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.9.4-r1.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.9.4-r1.ebuild
@@ -14,7 +14,7 @@ SRC_URI+=" verify-sig? ( mirror://gnupg/${PN}/${P}.tar.bz2.sig )"
LICENSE="LGPL-2.1 MIT"
SLOT="0/20" # subslot = soname major version
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="+asm cpu_flags_arm_neon cpu_flags_arm_aes cpu_flags_arm_sha1 cpu_flags_arm_sha2 cpu_flags_ppc_altivec cpu_flags_ppc_vsx2 cpu_flags_ppc_vsx3 cpu_flags_x86_aes cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_padlock cpu_flags_x86_sha cpu_flags_x86_sse4_1 doc o-flag-munging static-libs"
+IUSE="+asm custom-cflags cpu_flags_arm_neon cpu_flags_arm_aes cpu_flags_arm_sha1 cpu_flags_arm_sha2 cpu_flags_ppc_altivec cpu_flags_ppc_vsx2 cpu_flags_ppc_vsx3 cpu_flags_x86_aes cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_padlock cpu_flags_x86_sha cpu_flags_x86_sse4_1 doc static-libs"
# Build system only has --disable-arm-crypto-support right now
# If changing this, update src_configure logic too.
@@ -93,7 +93,7 @@ multilib_src_configure() {
$(use_enable cpu_flags_x86_sse4_1 sse41-support)
# required for sys-power/suspend[crypt], bug 751568
$(use_enable static-libs static)
- $(use_enable o-flag-munging O-flag-munging)
+ $(use_enable !custom-cflags O-flag-munging)
# disabled due to various applications requiring privileges
# after libgcrypt drops them (bug #468616)