summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ada/gprconfig_kb/gprconfig_kb-23.0.0-r3.ebuild4
-rw-r--r--dev-ada/gprconfig_kb/gprconfig_kb-23.0.0-r4.ebuild4
-rw-r--r--dev-ada/gprconfig_kb/gprconfig_kb-24.0.0.ebuild2
-rw-r--r--eclass/ada.eclass10
4 files changed, 12 insertions, 8 deletions
diff --git a/dev-ada/gprconfig_kb/gprconfig_kb-23.0.0-r3.ebuild b/dev-ada/gprconfig_kb/gprconfig_kb-23.0.0-r3.ebuild
index 2b2e86d52990..5438b3d85e97 100644
--- a/dev-ada/gprconfig_kb/gprconfig_kb-23.0.0-r3.ebuild
+++ b/dev-ada/gprconfig_kb/gprconfig_kb-23.0.0-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -23,7 +23,7 @@ src_prepare() {
default
sed -i \
- -e "s:@VER@:${GCC_PV}:g" \
+ -e "s:@VER@:${GCCPV}:g" \
db/compilers.xml \
db/gnat.xml \
db/c.xml \
diff --git a/dev-ada/gprconfig_kb/gprconfig_kb-23.0.0-r4.ebuild b/dev-ada/gprconfig_kb/gprconfig_kb-23.0.0-r4.ebuild
index 5e6e81063638..7efe5bff1097 100644
--- a/dev-ada/gprconfig_kb/gprconfig_kb-23.0.0-r4.ebuild
+++ b/dev-ada/gprconfig_kb/gprconfig_kb-23.0.0-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -23,7 +23,7 @@ src_prepare() {
default
sed -i \
- -e "s:@VER@:${GCC_PV}:g" \
+ -e "s:@VER@:${GCCPV}:g" \
db/compilers.xml \
db/gnat.xml \
db/c.xml \
diff --git a/dev-ada/gprconfig_kb/gprconfig_kb-24.0.0.ebuild b/dev-ada/gprconfig_kb/gprconfig_kb-24.0.0.ebuild
index c7156f1bd51c..2ef854ed40ca 100644
--- a/dev-ada/gprconfig_kb/gprconfig_kb-24.0.0.ebuild
+++ b/dev-ada/gprconfig_kb/gprconfig_kb-24.0.0.ebuild
@@ -22,7 +22,7 @@ src_prepare() {
default
sed -i \
- -e "s:@VER@:${GCC_PV}:g" \
+ -e "s:@VER@:${GCCPV}:g" \
db/compilers.xml \
db/gnat.xml \
db/c.xml \
diff --git a/eclass/ada.eclass b/eclass/ada.eclass
index e5b62951917a..3c3fa3c01453 100644
--- a/eclass/ada.eclass
+++ b/eclass/ada.eclass
@@ -1,4 +1,4 @@
-# Copyright 2019-2023 Gentoo Authors
+# Copyright 2019-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: ada.eclass
@@ -261,6 +261,10 @@ ada_export() {
export GCC_PV=${gcc_pv}
debug-print "${FUNCNAME}: GCC_PV = ${GCC_PV}"
;;
+ GCCPV)
+ export GCCPV=${gcc_pv}
+ debug-print "${FUNCNAME}: GCCPV = ${GCC_PV}"
+ ;;
GNAT)
export GNAT=${EPREFIX}/usr/bin/gnat-${gcc_pv}
debug-print "${FUNCNAME}: GNAT = ${GNAT}"
@@ -465,7 +469,7 @@ ada_setup() {
if [[ ${#_ADA_SUPPORTED_IMPLS[@]} -eq 1 ]]; then
if use "ada_target_${_ADA_SUPPORTED_IMPLS[0]}"; then
# Only one supported implementation, enable it explicitly
- ada_export "${_ADA_SUPPORTED_IMPLS[0]}" EADA GCC_PV GNAT GNATBIND GNATLS GNATMAKE
+ ada_export "${_ADA_SUPPORTED_IMPLS[0]}" EADA GCCPV GCC_PV GNAT GNATBIND GNATLS GNATMAKE
ada_wrapper_setup
fi
else
@@ -481,7 +485,7 @@ ada_setup() {
die "More than one implementation in ADA_TARGET."
fi
- ada_export "${impl}" EADA GCC_PV GNAT GNATBIND GNATLS GNATMAKE
+ ada_export "${impl}" EADA GCCPV GCC_PV GNAT GNATBIND GNATLS GNATMAKE
ada_wrapper_setup
fi
done