summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/django-rq/Manifest1
-rw-r--r--dev-python/django-rq/django-rq-2.4.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/django-rq/Manifest b/dev-python/django-rq/Manifest
index 92060c487fe5..e4fa75e6a66b 100644
--- a/dev-python/django-rq/Manifest
+++ b/dev-python/django-rq/Manifest
@@ -1 +1,2 @@
DIST django-rq-2.3.2.tar.gz 41038 BLAKE2B 837a8f819e9a91763b2d4ec961257d429e6d686fbaaa181d7fbe41efd9e08d958c5c340e4e1a4c8f0ef4063e985d3df82d8ea2c6a7cdea872b330dd545660e31 SHA512 8cf59aae163034240bfecda5f332dcc590813445cb2fc14bee15459ec8d4c50a36ab56865b3ce9360968451695e7a6d5eca5da26ef63c29dbc9dd58af8f16b98
+DIST django-rq-2.4.0.tar.gz 42455 BLAKE2B b60268625e8d57f1975c47df1dff72599fcab9eba0b43020196329cfc3c5447ce1bf9082338143f3f1d31434a8407d7a0e00b4dca64f2797ec54983930200798 SHA512 b1eec3f7e906bb4e553501940b9913727c8b21509fa10dd98ab5ad9f5625aaadd3f9c749824ad130005ac2a2ad8d27e8c8834466334f9bc09c438fcbd1cff344
diff --git a/dev-python/django-rq/django-rq-2.4.0.ebuild b/dev-python/django-rq/django-rq-2.4.0.ebuild
new file mode 100644
index 000000000000..0f5a386b6fbb
--- /dev/null
+++ b/dev-python/django-rq/django-rq-2.4.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="An app that provides django integration for RQ (Redis Queue)"
+HOMEPAGE="https://github.com/rq/django-rq"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-2.0[${PYTHON_USEDEP}]
+ >=dev-python/rq-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/redis-py-3.0.0[${PYTHON_USEDEP}]
+"