summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-action/violetland/files/violetland-0.4.3-boost150.patch8
-rw-r--r--games-action/violetland/violetland-0.4.3-r1.ebuild57
2 files changed, 61 insertions, 4 deletions
diff --git a/games-action/violetland/files/violetland-0.4.3-boost150.patch b/games-action/violetland/files/violetland-0.4.3-boost150.patch
index 4e700ca9e3d4..5ddd5e8445b8 100644
--- a/games-action/violetland/files/violetland-0.4.3-boost150.patch
+++ b/games-action/violetland/files/violetland-0.4.3-boost150.patch
@@ -1,5 +1,5 @@
---- CMakeLists.txt.old 2012-11-05 15:19:11.501044743 +0100
-+++ CMakeLists.txt 2012-11-05 15:19:25.415250207 +0100
+--- a/CMakeLists.txt 2012-11-05 15:19:11.501044743 +0100
++++ b/CMakeLists.txt 2012-11-05 15:19:25.415250207 +0100
@@ -8,7 +8,6 @@
find_package(SDL_mixer REQUIRED)
find_package(OpenGL REQUIRED)
@@ -8,8 +8,8 @@
if(${MINGW})
set(INTL_LIBRARY intl)
---- src/system/utility/FileUtility.cpp.old 2012-11-05 21:26:07.865488297 +0100
-+++ src/system/utility/FileUtility.cpp 2012-11-05 21:30:44.881208230 +0100
+--- a/src/system/utility/FileUtility.cpp 2012-11-05 21:26:07.865488297 +0100
++++ b/src/system/utility/FileUtility.cpp 2012-11-05 21:30:44.881208230 +0100
@@ -20,7 +20,7 @@
while (dir_it != boost::filesystem::directory_iterator()) {
diff --git a/games-action/violetland/violetland-0.4.3-r1.ebuild b/games-action/violetland/violetland-0.4.3-r1.ebuild
new file mode 100644
index 000000000000..a3b711ae9e6a
--- /dev/null
+++ b/games-action/violetland/violetland-0.4.3-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils multilib toolchain-funcs flag-o-matic cmake-utils
+
+DESCRIPTION="Help a girl named Violet in the struggle with hordes of monsters"
+HOMEPAGE="https://code.google.com/p/violetland/"
+SRC_URI="https://github.com/ooxi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost[threads(+)]
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf
+ virtual/glu
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-boost150.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "/README_EN.TXT/d" \
+ -e "/README_RU.TXT/d" \
+ CMakeLists.txt || die "sed failed"
+}
+
+src_configure() {
+ mycmakeargs=(
+ "-DCMAKE_INSTALL_PREFIX=/usr"
+ "-DDATA_INSTALL_DIR=/usr/share/${PN}"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ DOCS="README_EN.TXT CHANGELOG" cmake-utils_src_install
+ newicon icon-light.png ${PN}.png
+ make_desktop_entry ${PN} VioletLand
+}