summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/hivex/hivex-1.3.14.ebuild5
-rw-r--r--app-misc/hivex/hivex-1.3.18.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/app-misc/hivex/hivex-1.3.14.ebuild b/app-misc/hivex/hivex-1.3.14.ebuild
index 9f629900febb..cd4e1de9670b 100644
--- a/app-misc/hivex/hivex-1.3.14.ebuild
+++ b/app-misc/hivex/hivex-1.3.14.ebuild
@@ -17,7 +17,7 @@ SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="ocaml readline +perl python test static-libs ruby"
+IUSE="ocaml readline +perl python test ruby"
RDEPEND="
virtual/libiconv
@@ -82,6 +82,7 @@ src_configure() {
--disable-ruby
$(use_enable python)
--disable-rpath
+ --disable-static
)
econf ${myeconfargs[@]}
@@ -102,4 +103,6 @@ src_install() {
if use perl; then
perl_delete_localpod
fi
+
+ find "${ED}" -name '*.la' -delete || die
}
diff --git a/app-misc/hivex/hivex-1.3.18.ebuild b/app-misc/hivex/hivex-1.3.18.ebuild
index dad58992eb7d..568b03b92bd9 100644
--- a/app-misc/hivex/hivex-1.3.18.ebuild
+++ b/app-misc/hivex/hivex-1.3.18.ebuild
@@ -17,7 +17,7 @@ SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="ocaml readline +perl python test static-libs ruby"
+IUSE="ocaml readline +perl python test ruby"
RDEPEND="
virtual/libiconv
@@ -82,6 +82,7 @@ src_configure() {
--disable-ruby
$(use_enable python)
--disable-rpath
+ --disable-static
)
econf ${myeconfargs[@]}
@@ -105,4 +106,6 @@ src_install() {
if use perl; then
perl_delete_localpod
fi
+
+ find "${ED}" -name '*.la' -delete || die
}