summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/buildah/Manifest1
-rw-r--r--app-emulation/buildah/buildah-1.0.ebuild46
2 files changed, 0 insertions, 47 deletions
diff --git a/app-emulation/buildah/Manifest b/app-emulation/buildah/Manifest
index 609d9b7c8847..a7372b56026c 100644
--- a/app-emulation/buildah/Manifest
+++ b/app-emulation/buildah/Manifest
@@ -1,2 +1 @@
-DIST buildah-1.0.tar.gz 2865669 BLAKE2B 7749ed00637fff9c2bcee63ef9e8985b3e6e2abff1c1f4787dc0730b9765576fac9173dd05cbc289aed3c0d20ff374a78976beb86c73adb221184415e4906a41 SHA512 17779e5bbc20fff6da607898620a8193e11ef13ddc033e7868776aab53a710e09428dca0450f11368d750bf7179fd4850ac3a8a445bd9537d987bd837853f4e5
DIST buildah-1.1.tar.gz 4253820 BLAKE2B ae30a677a2f569d87da0ab85732078912598cf25f7b22ad25540f5d89797983a8549eef1bc8d151d4e0be078b97e024df145bb882bdd8443becb07774bfb5875 SHA512 9957590d7413436195307746682496616fd2350b832242f33fb4cb07c1144addae445eeff062f403d26a68329f1153468489032bc9bbcf870839c760a720ef95
diff --git a/app-emulation/buildah/buildah-1.0.ebuild b/app-emulation/buildah/buildah-1.0.ebuild
deleted file mode 100644
index baf50ef426d8..000000000000
--- a/app-emulation/buildah/buildah-1.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit bash-completion-r1 golang-vcs-snapshot
-
-KEYWORDS="~amd64"
-DESCRIPTION="A tool that facilitates building OCI images"
-HOMEPAGE="https://github.com/projectatomic/buildah"
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-EGO_PN="${HOMEPAGE#*//}"
-EGIT_COMMIT="v${PV}"
-GIT_COMMIT="1ab80bc"
-SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-RDEPEND="app-crypt/gpgme:=
- app-emulation/skopeo
- dev-libs/libgpg-error:=
- dev-libs/libassuan:=
- sys-fs/lvm2:=
- sys-libs/libseccomp:="
-DEPEND="${RDEPEND}"
-RESTRICT="test"
-S="${WORKDIR}/${P}/src/${EGO_PN}"
-
-src_prepare() {
- default
- sed -e 's|^\(GIT_COMMIT := \).*|\1'${GIT_COMMIT}'|' -i Makefile || die
-}
-
-src_compile() {
- GOPATH="${WORKDIR}/${P}" emake all
-}
-
-src_install() {
- dodoc README.md
- doman docs/*.1
- dodoc -r docs/tutorials
- dobin ${PN} imgtype
- dobashcomp contrib/completions/bash/buildah
-}
-
-src_test() {
- GOPATH="${WORKDIR}/${P}" emake test-unit
-}