summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libevdev/Manifest1
-rw-r--r--dev-libs/libevdev/libevdev-1.13.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/libevdev/Manifest b/dev-libs/libevdev/Manifest
index 840cf81147dd..9f32029ff8da 100644
--- a/dev-libs/libevdev/Manifest
+++ b/dev-libs/libevdev/Manifest
@@ -1 +1,2 @@
DIST libevdev-1.12.1.tar.xz 446476 BLAKE2B 3b73c50b5e0bdf6dac001c7e34338ece2ba796af711d8f6f9c2928f93a8f41ee484e067c3cb02878de49d631de87229d4b1a377123e385af5997e11f7c556510 SHA512 eefce287a665e4f89eb2e0437dfefd45ecf8925c7dac35a1bdd46158541f77f2032c6146900a30a01321751d55a9b537bd1d61777cca9cfa02c39a6e31c97be4
+DIST libevdev-1.13.0.tar.xz 451328 BLAKE2B 07b15bf46ca3b01d9a93da8d93fd60b2f1eb95961f0f202a321030e145528453375f1e4fa3458adac3f3346cc26642538251b35002f18f9802799e4732d39f3e SHA512 f30f14c44ef4d4829625aa4c28f10555f333905486f9d39c18cd3ca35e87128a0c24c1bc18ca37b6bf98bc8f7fad27e1bc68678a58e6e6fff3b8d99502ac6905
diff --git a/dev-libs/libevdev/libevdev-1.13.0.ebuild b/dev-libs/libevdev/libevdev-1.13.0.ebuild
new file mode 100644
index 000000000000..9f3d0d16e6a3
--- /dev/null
+++ b/dev-libs/libevdev/libevdev-1.13.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit meson-multilib python-any-r1
+
+DESCRIPTION="Handler library for evdev events"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libevdev/ https://gitlab.freedesktop.org/libevdev/libevdev"
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/libevdev/libevdev.git"
+ inherit git-r3
+else
+ SRC_URI="https://www.freedesktop.org/software/libevdev/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND="test? ( dev-libs/check[${MULTILIB_USEDEP}] )"
+BDEPEND="
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig
+"
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature doc documentation)
+ $(meson_feature test tests)
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ meson_src_test -t 100
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ local HTML_DOCS=( doc/html/. )
+ einstalldocs
+ fi
+}