summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-fs/smbtatools/smbtatools-1.2.6-r1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/net-fs/smbtatools/smbtatools-1.2.6-r1.ebuild b/net-fs/smbtatools/smbtatools-1.2.6-r1.ebuild
index c2d65eba3364..6a71507b1258 100644
--- a/net-fs/smbtatools/smbtatools-1.2.6-r1.ebuild
+++ b/net-fs/smbtatools/smbtatools-1.2.6-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=6
-inherit cmake-utils
+inherit toolchain-funcs cmake-utils
DESCRIPTION="Tools for configuration and query of SMB Traffic Analyzer"
HOMEPAGE="https://github.com/hhetter/smbtatools"
@@ -37,10 +37,11 @@ DOCS="doc/smbta-guide.html doc/gfx/*.png"
PATCHES=( "${FILESDIR}"/${P}-fix-cmake.patch )
src_configure() {
+ local PKG_CONFIG=$(tc-getPKG_CONFIG)
local mycmakeargs=(
-Ddebug=$(usex debug)
- -DLIBSMBCLIENT_LIBRARIES="$(pkg-config --libs smbclient)"
- -DLIBSMBCLIENT_INCLUDE_DIRS="$(pkg-config --variable includedir smbclient)"
+ -DLIBSMBCLIENT_LIBRARIES="$(${PKG_CONFIG} --libs smbclient)"
+ -DLIBSMBCLIENT_INCLUDE_DIRS="$(${PKG_CONFIG} --variable includedir smbclient)"
)
cmake-utils_src_configure