summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pycxx/Manifest1
-rw-r--r--dev-python/pycxx/pycxx-6.2.5.ebuild36
2 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/pycxx/Manifest b/dev-python/pycxx/Manifest
index f90b016296b4..c59906a43753 100644
--- a/dev-python/pycxx/Manifest
+++ b/dev-python/pycxx/Manifest
@@ -1,2 +1 @@
-DIST pycxx-6.2.5.tar.gz 141302 SHA256 f125c1b569d32dcfc5bdca565be0311306a2d759196460a5cac665cb515b014c SHA512 c7a5eeacdcb3f68e0a2336a33e6a84d6a7b240e4d232ce0f2676c4a467bf2c8b109eebd63ee42b655efa1f1993fe66a590459a9fbe7315b6c0a57501c73ff3b4 WHIRLPOOL 0792cf9050a21a3774d13124838300663f3b0fe458a243d9aadff2177772e5be0516e0c8a806c572401c28d59c98a252162267c65fc9010a6ea0af0bbdb6c254
DIST pycxx-6.2.6.tar.gz 141547 SHA256 3e960db53dea640473410ea20063afe7fcfcb61c107334d7ff6af96d384c11fe SHA512 9a6c30acb99c112497c02fb0826dc0197bbf4b813d25eab3f7d6537dfd83db8150c94f617f79810bbcca64496b8d6e67b1a41446523d66031c54c21e0425ea0c WHIRLPOOL 570cc1ccd12748481c74aefe863a2cef2d2d048ddbeceeeea01477a6d1765f38582f3c9112c8d5fddf6f534b91c74aea11b38aab8da04ced18280047a0821090
diff --git a/dev-python/pycxx/pycxx-6.2.5.ebuild b/dev-python/pycxx/pycxx-6.2.5.ebuild
deleted file mode 100644
index f8e34a971b9f..000000000000
--- a/dev-python/pycxx/pycxx-6.2.5.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit eutils distutils-r1
-
-DESCRIPTION="Set of facilities to extend Python with C++"
-HOMEPAGE="http://cxx.sourceforge.net"
-SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="doc examples"
-
-python_prepare_all() {
- # Without this, pysvn fails.
- # CXX/Python2/Config.hxx: No such file or directory
- sed -e "/^#include/s:/Python[23]/:/:" -i CXX/*/*.hxx || die "sed failed"
-
- # Remove python2 print statement
- echo > Lib/__init__.py || die
-
- local PATCHES=(
- "${FILESDIR}/${PN}-6.2.3-installation.patch"
- )
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( Doc/ )
- use examples && local EXAMPLES=( Demo/Python{2,3}/ )
- distutils-r1_python_install_all
-}