summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/vendor-reset/Manifest1
-rw-r--r--app-emulation/vendor-reset/vendor-reset-0.1.0.ebuild46
2 files changed, 0 insertions, 47 deletions
diff --git a/app-emulation/vendor-reset/Manifest b/app-emulation/vendor-reset/Manifest
index 6ddfbd7eb277..d6e8905b5c12 100644
--- a/app-emulation/vendor-reset/Manifest
+++ b/app-emulation/vendor-reset/Manifest
@@ -1,2 +1 @@
-DIST vendor-reset-0.1.0.tar.gz 12718324 BLAKE2B 762ec8bc289b572ab8f8ecc3fa233e3c78c48c48a261c58ce1be9c10356a55957e0bd8fd01e3143443be74236bf9ed540b84d332788c67aa949599ccc5a564d3 SHA512 ed4dcb1a71fa8901732e729d37b501ac105cc2c93d0666e44c08e311d99a244027339d5709a9305ff992ca2acb2f337793cdb1f9369197911985cd20d6f3139f
DIST vendor-reset-0.1.1_pre20221205.tar.gz 12725340 BLAKE2B 5f2e34b74e83c8f48daad8d2c714872ab23f50cb0fad6b5c7920476b43c2fbfcf5543e923c506dfb2d8c33846e8fdd08c7d20b30fcc053f2c191d813872b44c5 SHA512 87a3c64d917e6a44308115480f14956f65a9f84fef70de29feebe3fcd7d522b59a3dbcb5fc9a340ac9b7a3612a29ed696b4f52648f86a0d877b915c97c5a4cc9
diff --git a/app-emulation/vendor-reset/vendor-reset-0.1.0.ebuild b/app-emulation/vendor-reset/vendor-reset-0.1.0.ebuild
deleted file mode 100644
index ec57b37fd6fe..000000000000
--- a/app-emulation/vendor-reset/vendor-reset-0.1.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-mod
-
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/gnif/vendor-reset.git"
- EGIT_BRANCH="master"
- inherit git-r3
-else
- KEYWORDS="~amd64"
- SRC_URI="https://github.com/gnif/vendor-reset/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-DESCRIPTION="Linux kernel vendor specific hardware reset module"
-HOMEPAGE="https://github.com/gnif/vendor-reset"
-LICENSE="GPL-2"
-SLOT="0"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/Fix-5.11-build.patch" )
-
-pkg_setup() {
- local CONFIG_CHECK="FTRACE KPROBES PCI_QUIRKS KALLSYMS FUNCTION_TRACER"
- linux-mod_pkg_setup
-}
-
-src_compile() {
- set_arch_to_kernel
- default
-}
-
-src_install() {
- set_arch_to_kernel
- emake \
- DESTDIR="${ED}" \
- INSTALL_MOD_PATH="${ED}" \
- install
-
- insinto /etc/modules-load.d/
- newins "${FILESDIR}"/modload.conf vendor-reset.conf
-}