summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/conf2struct/conf2struct-0_pre0.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-util/conf2struct/conf2struct-0_pre0.ebuild b/dev-util/conf2struct/conf2struct-0_pre0.ebuild
deleted file mode 100644
index 33d18ebd06e3..000000000000
--- a/dev-util/conf2struct/conf2struct-0_pre0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit flag-o-matic systemd toolchain-funcs
-
-DESCRIPTION="Create C parsers for libconfig and command-line"
-HOMEPAGE="https://github.com/yrutschle/conf2struct/"
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/yrutschle/conf2struct.git"
- inherit git-r3
-else
- KEYWORDS="~amd64"
- GIT_COMMIT="10ea3356b65e712fb000f4d37f00e1dc09c1e722"
- SRC_URI="https://github.com/yrutschle/conf2struct/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${PN}-${GIT_COMMIT}"
-fi
-
-PATCHES=(
- "${FILESDIR}/${P}-install-and-uninstall.patch"
- "${FILESDIR}/${P}-cc-and-cflags.patch"
- "${FILESDIR}/${P}-destdir.patch"
- "${FILESDIR}/${P}-install-not-run-all.patch"
- "${FILESDIR}/${P}-dest-exists.patch"
-)
-
-LICENSE="BSD-2"
-SLOT="0"
-IUSE=""
-
-RDEPEND="dev-libs/libconfig
- dev-perl/Conf-Libconfig"
-DEPEND="${RDEPEND}"
-
-src_compile(){
- # -j1 due to parallel make issue reported upstream at: https://github.com/yrutschle/conf2struct/issues/10
- emake -j1
-}
-
-src_install(){
- emake DESTDIR="${D}" prefix="${EPREFIX%/}/usr" install
-}