summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/arb/Manifest1
-rw-r--r--sci-biology/arb/arb-6.0.6.ebuild100
-rw-r--r--sci-biology/arb/files/arb-6.0.6-arb_install.patch99
-rw-r--r--sci-biology/arb/files/arb-6.0.6-glapi.patch15
-rw-r--r--sci-biology/arb/files/arb-6.0.6-tc-flags.patch58
5 files changed, 273 insertions, 0 deletions
diff --git a/sci-biology/arb/Manifest b/sci-biology/arb/Manifest
index 2ec5a49babc9..0b6b8b4583f2 100644
--- a/sci-biology/arb/Manifest
+++ b/sci-biology/arb/Manifest
@@ -5,3 +5,4 @@ DIST arb-5.2-linker.patch.bz2 4441 SHA256 3b804fca56e920f83b79f7cdfb124769bfa677
DIST arb-5.2.tgz 9729004 SHA256 cd68cfae317aae378da69c4c4ec8036a2babec064896d0b9d845fac2133f6edd SHA512 d1f9f7273645af7da0e949971b705303f0715ac98869acc0f75d62bfe88751709f5d5dbbc3079b0abe461ddce8262b165426e347ad28bc28a55cdf6c29b5ff56 WHIRLPOOL ec5422b4b689a77b479231c04d7b5a2f4f0ef23cd06b024920432134132d7c2c5b24c407b2561074a41606e7945ce88970789f5db82e43cc9ef9313ea48c0583
DIST arb-5.3-linker.patch.xz 3604 SHA256 09580d0c1ff54c4956382cef850aecb9008e62e083f3246604cac72f06d05e95 SHA512 8eb072cd5a3c13b2a6ad0e40f3b155096168dbd70a6e13878d4a62e563903742442373a5e3032d6f78beefe774943fef86f6060e89acd0d18b95a7c0d4a8dec7 WHIRLPOOL f77d767c5b5c911ba3ddc9ef5b3e482cb1975b5d56f50b76166bd4a0b55e251e73eeee46709147207b2f3553d482bab99398d8bd03aef8f0b79928a8a66d0bfe
DIST arb-5.3.tgz 9543106 SHA256 c40a3f33f39996e3e331fb41acd452e5a20b7e638b856b0b66ea8e07c977abf8 SHA512 faa924b9c6f437f77ed637798c6fe5fe5c2e6a0f2efc9c1f735133fab9c037c7039fc4ef6f6e5b0408fc39ea5c69c747b1887689f4621b608add593d77930282 WHIRLPOOL 9b4723043b4f8b9a68973f49cb7dc8c3cf3558ff646d20f7d4f20f6e4797b6c9a986fdb1dc47178f2c80251db59f61dffd1b01bbdd880f864fc749ef59e62958
+DIST arb-6.0.6.tgz 13286019 SHA256 8b1fc3fd11bbb05aca4731ac8803c004a4f2b6b87c11b543660d07ea349a6c21 SHA512 053d4d964d8a299f86d4cab9113f0d2181780bf51e0ccec0459a4d568d09bb4e9723fa8493d8e4fa5c72e6d1f022241721cadf7ceb75ee27142d48f2f9f269b4 WHIRLPOOL 199ad8a5eac7d5e3d84520ba9a0de4bb0202906e3b71746eef929978d5a28c092c7aa204d4035301ceb42f5385c6077cc3c53aba5e8d9c3e3665cf83020387c4
diff --git a/sci-biology/arb/arb-6.0.6.ebuild b/sci-biology/arb/arb-6.0.6.ebuild
new file mode 100644
index 000000000000..e2f81e08471e
--- /dev/null
+++ b/sci-biology/arb/arb-6.0.6.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tools for DNA/RNA sequence database handling and phylogenetic analysis"
+HOMEPAGE="http://www.arb-home.de/"
+SRC_URI="http://download.arb-home.de/release/${P}/${P}-source.tgz -> ${P}.tgz"
+
+SLOT="0"
+LICENSE="arb"
+IUSE="debug +opengl test"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="app-text/sablotron
+ media-libs/libpng:=
+ media-libs/tiff:=
+ www-client/lynx
+ x11-libs/libXaw
+ x11-libs/libXpm
+ x11-libs/motif:0
+ opengl? (
+ media-libs/glew:=
+ media-libs/freeglut
+ || (
+ media-libs/mesa[motif]
+ ( media-libs/mesa x11-libs/libGLw ) ) )"
+DEPEND="${CDEPEND}
+ sys-process/time
+ x11-misc/makedepend"
+RDEPEND="${CDEPEND}
+ sci-visualization/gnuplot"
+
+# Almost half of tests are broken with debug
+RESTRICT="debug? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.0.6-glapi.patch
+ "${FILESDIR}"/${PN}-6.0.6-tc-flags.patch
+ "${FILESDIR}"/${PN}-6.0.6-arb_install.patch
+)
+
+src_unpack() {
+ default
+ mv arbsrc* ${P} || die
+}
+
+src_prepare() {
+ default
+
+ cp config.makefile.template config.makefile
+ mkdir "${S}"/patches.arb || die # Test script expects ${ARBHOME}/patches.arb to exist
+
+ if use amd64; then
+ sed -i -e 's@ARB_64 := 0@ARB_64 := 1@' config.makefile || die
+ fi
+ if use opengl; then
+ sed -i -e 's@OPENGL := 0@OPENGL := 1@' config.makefile || die
+ fi
+ if use test; then
+ sed -i -e 's@UNIT_TESTS := 0@UNIT_TESTS := 1@' config.makefile || die
+ fi
+ if use debug; then
+ sed -i -e 's@DEBUG := 0@DEBUG := 1@' \
+ -e 's@DEBUG_GRAPHICS := 0@DEBUG_GRAPHICS := 1@' config.makefile || die
+ fi
+}
+
+src_compile() {
+ emake ARBHOME="${S}" PATH="${S}/bin:${PATH}" LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}" \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" build
+}
+
+src_test() {
+ emake ARBHOME="${S}" PATH="${S}/bin:${PATH}" LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}" \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" run_tests
+}
+
+src_install() {
+ emake ARBHOME="${S}" PATH="${S}/bin:${PATH}" LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}" \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" prepare_libdir
+ "${S}"/util/arb_compress || die
+ if use amd64; then
+ mv arb.tgz arb.64.gentoo.tgz || die
+ fi
+ if use x86; then
+ mv arb.tgz arb.32.gentoo.tgz || die
+ fi
+ ln -s arb.*.tgz arb.tgz || die
+ ARBHOME="${D}/opt/arb" "${S}/arb_install.sh" || die
+
+ cat <<- EOF > "${S}/99${PN}" || die
+ ARBHOME=/opt/arb
+ PATH=/opt/arb/bin
+ LD_LIBRARY_PATH=/opt/arb/lib
+ EOF
+ doenvd "${S}/99${PN}"
+}
diff --git a/sci-biology/arb/files/arb-6.0.6-arb_install.patch b/sci-biology/arb/files/arb-6.0.6-arb_install.patch
new file mode 100644
index 000000000000..926c8e0e2894
--- /dev/null
+++ b/sci-biology/arb/files/arb-6.0.6-arb_install.patch
@@ -0,0 +1,99 @@
+--- a/arb_install.sh
++++ b/arb_install.sh
+@@ -13,7 +13,6 @@
+ cont() {
+ echo "Warning: $@" 1>&2
+ echo 'Do you want to continue [y]'
+- read var
+ case "$var" in
+ n) err "Script aborted by user" ;;
+ *) echo 'Continuing...' ;;
+@@ -79,7 +78,6 @@
+ fi
+
+ echo "Enter full installation path: [${ARBHOME:-/usr/arb}]"
+-read ARBHOMEI
+ echo
+ echo
+
+@@ -127,7 +125,6 @@
+ echo ' You can delete the old directory before installing ARB'
+ echo ' or only update/change options of the old version.'
+ echo 'Delete old directory (y/n)[n]?'
+- read delete_dir
+ echo
+ case "$delete_dir" in
+ y)
+@@ -163,7 +160,6 @@
+ separator
+ echo "Old ARB package found (type n to change only some options)."
+ echo " Do you want to update the old package: (y/n)[y]"
+- read var;
+ case "$var" in
+ n)
+ echo "Old version unchanged";;
+@@ -197,7 +193,6 @@
+ echo ' 2. "Path" to link pt_server data directory to'
+ echo " (if you choose this option you won't loose your PT-Servers when doing future software updates)"
+ echo 'Enter path:'
+-read pt_dir
+ echo
+ case "$pt_dir" in
+ "")
+@@ -222,7 +217,6 @@
+ if test -d ${ARBHOME}/lib/pts; then
+ echo ">>> data in default location found"
+ echo 'Do you want to remove old ptserver data (recommended)? [y]'
+- read ANSWER
+ case "$ANSWER" in
+ n) echo 'data not deleted' ;;
+ *) rm -r lib/pts
+@@ -247,7 +241,6 @@
+ echo ' n: if PT_SERVER files shall only be changable by administrator'
+ echo ' or simply press return to keep the settings of an old installation.'
+ echo 'Should everybody be allowed to build/update PT_SERVER files (y/n/dont_change)[dont_change]?'
+-read var
+ echo
+ case "$var" in
+ y)
+@@ -273,7 +266,6 @@
+ echo ' n: if there are some mean untrusty users'
+ echo ' or simply press return to keep the old settings'
+ echo 'Do you trust your users (y/n/dont_change)[dont_change]?'
+-read var
+ echo
+ case "$var" in
+ y)
+@@ -310,7 +302,6 @@
+ echo 'Choose (s/n)[s]?'
+
+ fi
+-read var
+ echo
+
+
+@@ -322,7 +313,6 @@
+ n)
+ separator
+ echo "Enter the name of your host for the pt_server"
+- read host
+ echo "Checking connection to $host"
+ if ssh $host ls >/dev/zero; then
+ echo ">>> ssh $host ok"
+@@ -341,7 +331,7 @@
+ echo ">>> Installation Complete"
+
+ separator
+-SHELL_ANS=0
++SHELL_ANS=1
+
+ while [ "$SHELL_ANS" = "0" ]; do
+
+@@ -359,7 +349,6 @@
+
+ echo "Enter (1,2 or 3) to achieve further installation instructions:"
+
+- read var
+
+ echo '';
+ echo '**********************************************************************************************';
diff --git a/sci-biology/arb/files/arb-6.0.6-glapi.patch b/sci-biology/arb/files/arb-6.0.6-glapi.patch
new file mode 100644
index 000000000000..755cb6858624
--- /dev/null
+++ b/sci-biology/arb/files/arb-6.0.6-glapi.patch
@@ -0,0 +1,15 @@
+When built with USE=opengl, the macro GLAPI either doesn't get defined
+or gets undefed in some header. Header <GL/GLwMDrawA.h> seems to expect
+it to be defined as 'extern', as defining it as '__attribute__((visibility("default")))'
+leads to multiple definition errors.
+
+--- a/RNA3D/RNA3D_GlobalHeader.hxx
++++ b/RNA3D/RNA3D_GlobalHeader.hxx
+@@ -44,6 +44,7 @@
+ // Undefining it here does the job:
+ #undef __GLX_glx_h__
+ #include <GL/glx.h>
++#define GLAPI extern
+ #endif // OPEN_GL_WAY_TO_INCLUDE == 3
+ // ------------------------------
+
diff --git a/sci-biology/arb/files/arb-6.0.6-tc-flags.patch b/sci-biology/arb/files/arb-6.0.6-tc-flags.patch
new file mode 100644
index 000000000000..4c8f22d79409
--- /dev/null
+++ b/sci-biology/arb/files/arb-6.0.6-tc-flags.patch
@@ -0,0 +1,58 @@
+--- a/Makefile
++++ b/Makefile
+@@ -61,8 +61,8 @@
+ # compiler settings:
+ ifneq ($(CC),use__A_CC__instead_of__CC)
+
+-A_CC:=$(CC)# compile C
+-A_CXX:=$(CXX)# compile C++
++A_CC:=${CC}# compile C
++A_CXX:=${CXX}# compile C++
+
+ # uncomment to ensure no submakefile uses CC and CXX directly
+ override CC:=use__A_CC__instead_of__CC
+@@ -119,12 +119,7 @@
+ endif
+ endif
+
+-ifeq ($(USE_CLANG),1)
+-# accept all clang versions:
+ ALLOWED_COMPILER_VERSIONS=$(COMPILER_VERSION)
+-else
+-ALLOWED_COMPILER_VERSIONS=$(ALLOWED_gcc_VERSIONS)
+-endif
+
+ COMPILER_VERSION_ALLOWED=$(strip $(subst ___,,$(foreach version,$(ALLOWED_COMPILER_VERSIONS),$(findstring ___$(version)___,___$(COMPILER_VERSION)___))))
+
+@@ -184,20 +179,13 @@
+
+ shared_cflags :=# flags for shared lib compilation
+ lflags :=# linker flags
+-clflags :=# linker flags (when passed through gcc)
++clflags := ${LDFLAGS} # linker flags (when passed through gcc)
+ extended_warnings :=# warning flags for C and C++-compiler
+ extended_cpp_warnings :=# warning flags for C++-compiler only
+
+
+ ifeq ($(DEBUG),0)
+ dflags := -DNDEBUG# defines
+- ifeq ($(USE_CLANG),1)
+- cflags := -O3# compiler flags (C and C++)
+- else
+- cflags := -O3# compiler flags (C and C++)
+- lflags += -O2# linker flags
+- clflags += -Wl,-O2# passthrough linker flags
+- endif
+ endif
+
+ ifeq ($(DEBIAN),1)
+@@ -526,6 +514,9 @@
+ cxxflags += $(CPPFLAGS)
+ endif
+
++cflags := ${CFLAGS} $(cflags)
++cxxflags += ${CXXFLAGS}
++
+ ifeq ('$(USE_GCC_47_OR_HIGHER)','yes')
+ cxxflags += -std=gnu++11# see also TEMPLATES/cxxforward.h@USE_Cxx11
+ else