summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-simulation/corsix-th/Manifest1
-rw-r--r--games-simulation/corsix-th/corsix-th-0.21-r1.ebuild62
-rw-r--r--games-simulation/corsix-th/files/corsix-th-0.21-naming.patch17
-rw-r--r--games-simulation/corsix-th/files/corsix-th-nodoc.patch11
4 files changed, 0 insertions, 91 deletions
diff --git a/games-simulation/corsix-th/Manifest b/games-simulation/corsix-th/Manifest
index 53f07f345574..55ea375b4fe6 100644
--- a/games-simulation/corsix-th/Manifest
+++ b/games-simulation/corsix-th/Manifest
@@ -1,2 +1 @@
-DIST CorsixTH-0.21-Source.tar.gz 3908197 SHA256 9a8b54644e614dc13d4b5d97bf023b8e023e0186f931695b8f4ec7e4577a4ead SHA512 6f75772a7af0a09d216f042eda437e4159061637b404c0282472dab4751b7d515e25c6a922bb51051cfe7c351396491ac68d7969e3f37dafb1862fb6c85b6b52 WHIRLPOOL 69e3a57581e0a7446fda839284d2200ed8be559403504a42cfa187c8180689b175a96fb7b15b2b124ac3605dd936190f8ee882f4ea464acdc81157f598b0b20a
DIST corsix-th-0.30.tar.gz 4345385 SHA256 4947ebdc50b01fde0aca797250d50b9806b9e6f3f4323872fd914f033f4c92e7 SHA512 1afd9d68dd6db82393e454e2c234179029902b701aafe4d2ca76381be195acba55f0ee062ce071a78cf3f5e8762e25452f386276aecc1af816553532b870964a WHIRLPOOL b01a1d72c0408c1d7d7d0a72e55c9b9f0863acfe064c07f4920c3f66bfb29fb0acf0a7e4e1d80e214b2e81d073e070427fbd8fca9cd34e14cda561159a88d4d0
diff --git a/games-simulation/corsix-th/corsix-th-0.21-r1.ebuild b/games-simulation/corsix-th/corsix-th-0.21-r1.ebuild
deleted file mode 100644
index 663f04f271e4..000000000000
--- a/games-simulation/corsix-th/corsix-th-0.21-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils cmake-utils games
-
-MY_P="CorsixTH-${PV}-Source"
-
-DESCRIPTION="Open source clone of Theme Hospital"
-HOMEPAGE="https://code.google.com/p/corsix-th/"
-SRC_URI="https://corsix-th.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+ffmpeg truetype opengl +sdl +sound +midi"
-REQUIRED_USE="|| ( sdl opengl )"
-
-RDEPEND=">=dev-lang/lua-5.1
- media-libs/libsdl[X]
- ffmpeg? ( virtual/ffmpeg )
- truetype? ( media-libs/freetype:2 )
- opengl? ( virtual/opengl )
- sound? ( media-libs/sdl-mixer )
- midi? ( media-libs/sdl-mixer[timidity] )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-nodoc.patch"
-
- # Use a coherent naming for installation dir
- epatch "${FILESDIR}/${P}-naming.patch"
-}
-
-src_configure() {
- local mycmakeargs="$(cmake-utils_use_with opengl OPENGL) \
- $(cmake-utils_use_with sdl SDL) \
- $(cmake-utils_use_with sound AUDIO) \
- $(cmake-utils_use_with truetype FREETYPE2) \
- $(cmake-utils_use_with ffmpeg MOVIES) \
- -DCMAKE_INSTALL_PREFIX=${GAMES_DATADIR}"
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_install() {
- cmake-utils_src_install
-
- DOCS="CorsixTH/README.txt CorsixTH/changelog.txt" cmake-utils_src_install
- games_make_wrapper ${PN} "${GAMES_DATADIR}/${PN}/CorsixTH" || die
- make_desktop_entry ${PN} ${PN} \
- "${GAMES_DATADIR}/${PN}/CorsixTH.ico"
- prepgamesdirs
-}
diff --git a/games-simulation/corsix-th/files/corsix-th-0.21-naming.patch b/games-simulation/corsix-th/files/corsix-th-0.21-naming.patch
deleted file mode 100644
index b82b5fa91297..000000000000
--- a/games-simulation/corsix-th/files/corsix-th-0.21-naming.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- CorsixTH/CMakeLists.txt 2013-07-26 19:35:30.463506153 +0200
-+++ CorsixTH/CMakeLists.txt.new 2013-07-26 19:38:07.944473631 +0200
-@@ -222,10 +222,10 @@
- ENDIF()
-
- ELSE()
-- install(TARGETS CorsixTH RUNTIME DESTINATION CorsixTH)
-- install(DIRECTORY Lua Levels DESTINATION CorsixTH PATTERN "*.svn" EXCLUDE)
-- install(DIRECTORY Bitmap DESTINATION CorsixTH
-+ install(TARGETS CorsixTH RUNTIME DESTINATION corsix-th)
-+ install(DIRECTORY Lua Levels DESTINATION corsix-th PATTERN "*.svn" EXCLUDE)
-+ install(DIRECTORY Bitmap DESTINATION corsix-th
- FILES_MATCHING REGEX ".*\\.(tab|pal|dat|png)$"
- PATTERN "*.svn" EXCLUDE)
-- install(FILES CorsixTH.lua CorsixTH.ico DESTINATION CorsixTH )
-+ install(FILES CorsixTH.lua CorsixTH.ico DESTINATION corsix-th )
- ENDIF()
diff --git a/games-simulation/corsix-th/files/corsix-th-nodoc.patch b/games-simulation/corsix-th/files/corsix-th-nodoc.patch
deleted file mode 100644
index 0fcae9bcd702..000000000000
--- a/games-simulation/corsix-th/files/corsix-th-nodoc.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff --git a/CorsixTH/CMakeLists.txt b/CorsixTH/CMakeLists.txt
-index dfdb59e..9b97b3c 100755
---- a/CorsixTH/CMakeLists.txt
-+++ b/CorsixTH/CMakeLists.txt
-@@ -191,5 +191,5 @@ ELSE()
- install(DIRECTORY Bitmap DESTINATION CorsixTH
- FILES_MATCHING REGEX ".*\\.(tab|pal|dat|png)$"
- PATTERN "*.svn" EXCLUDE)
-- install(FILES CorsixTH.lua LICENSE.txt CorsixTH.ico DESTINATION CorsixTH )
-+ install(FILES CorsixTH.lua CorsixTH.ico DESTINATION CorsixTH )
- ENDIF()